summaryrefslogtreecommitdiff
path: root/gnu/packages/ssh.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-23 03:30:00 -0400
committerMark H Weaver <mhw@netris.org>2018-03-23 04:43:26 -0400
commit27b6adb715c0ac54888f451032736475f69ed12a (patch)
tree0dd8307431e6b3034bb7f02e0b0cbeae57953734 /gnu/packages/ssh.scm
parent4530e854f1ca25492a7dda2d0d438d222ff53eb4 (diff)
downloadgnu-guix-27b6adb715c0ac54888f451032736475f69ed12a.tar
gnu-guix-27b6adb715c0ac54888f451032736475f69ed12a.tar.gz
gnu: openssh: Use invoke.
* gnu/packages/ssh.scm (openssh)[arguments]: Use invoke and remove vestigial plumbing in the custom install phase.
Diffstat (limited to 'gnu/packages/ssh.scm')
-rw-r--r--gnu/packages/ssh.scm21
1 files changed, 10 insertions, 11 deletions
diff --git a/gnu/packages/ssh.scm b/gnu/packages/ssh.scm
index 050ef05f73..79aff945f3 100644
--- a/gnu/packages/ssh.scm
+++ b/gnu/packages/ssh.scm
@@ -184,17 +184,16 @@ a server that supports the SSH-2 protocol.")
(replace 'install
(lambda* (#:key outputs (make-flags '()) #:allow-other-keys)
;; install without host keys and system configuration files
- (and (zero? (apply system* "make" "install-nosysconf" make-flags))
- (begin
- (install-file "contrib/ssh-copy-id"
- (string-append (assoc-ref outputs "out")
- "/bin/"))
- (chmod (string-append (assoc-ref outputs "out")
- "/bin/ssh-copy-id") #o555)
- (install-file "contrib/ssh-copy-id.1"
- (string-append (assoc-ref outputs "out")
- "/share/man/man1/"))
- #t)))))))
+ (apply invoke "make" "install-nosysconf" make-flags)
+ (install-file "contrib/ssh-copy-id"
+ (string-append (assoc-ref outputs "out")
+ "/bin/"))
+ (chmod (string-append (assoc-ref outputs "out")
+ "/bin/ssh-copy-id") #o555)
+ (install-file "contrib/ssh-copy-id.1"
+ (string-append (assoc-ref outputs "out")
+ "/share/man/man1/"))
+ #t)))))
(synopsis "Client and server for the secure shell (ssh) protocol")
(description
"The SSH2 protocol implemented in OpenSSH is standardised by the