summaryrefslogtreecommitdiff
path: root/gnu/packages/spice.scm
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-07-24 19:52:26 +0200
committerLeo Famulari <leo@famulari.name>2016-07-28 17:08:41 -0400
commit289e472f56682e7e58479fbf58ca34cd98467672 (patch)
tree0d0dcadab1bd54d5ef72d6d19e87d70ac160acee /gnu/packages/spice.scm
parent2ef2654de44014664ad99d05e3095ff60535c611 (diff)
downloadgnu-guix-289e472f56682e7e58479fbf58ca34cd98467672.tar
gnu-guix-289e472f56682e7e58479fbf58ca34cd98467672.tar.gz
gnu: Add spice-protocol.
* gnu/packages/spice.scm (spice-protocol): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/spice.scm')
-rw-r--r--gnu/packages/spice.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/spice.scm b/gnu/packages/spice.scm
index 797b19a2e4..5f4df734e5 100644
--- a/gnu/packages/spice.scm
+++ b/gnu/packages/spice.scm
@@ -77,3 +77,23 @@ attached.")
system to use the host GPU to accelerate 3D rendering.")
(home-page "https://virgil3d.github.io")
(license (list license:expat license:bsd-3))))
+
+(define-public spice-protocol
+ (package
+ (name "spice-protocol")
+ (version "0.12.11")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://www.spice-space.org/download/releases/"
+ "spice-protocol-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "0c33kg3vdz3nnl2wjfbgmszz5hbjbvsw6map35dj9hxnpwwf9fi2"))))
+ (build-system gnu-build-system)
+ (synopsis "Protocol headers for the SPICE protocol")
+ (description "SPICE (the Simple Protocol for Independent Computing
+Environments) is a remote-display system built for virtual environments
+which allows users to view a desktop computing environment.")
+ (home-page "http://www.spice-space.org")
+ (license (list license:bsd-3 license:lgpl2.1+))))