summaryrefslogtreecommitdiff
path: root/gnu/packages/shells.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-07-15 18:46:57 -0400
committerLeo Famulari <leo@famulari.name>2017-07-17 11:48:46 -0400
commitda20c38f3524011195b4ab6a22ed8e7d4cb84889 (patch)
tree15dba5e1ee53bb26eeb62747677ca19237ff496a /gnu/packages/shells.scm
parent371ca85f52aa751522675be05152a50786130e9b (diff)
downloadgnu-guix-da20c38f3524011195b4ab6a22ed8e7d4cb84889.tar
gnu-guix-da20c38f3524011195b4ab6a22ed8e7d4cb84889.tar.gz
gnu: dash: Use the release tarball.
* gnu/packages/shells.scm (dash)[source]: Use the release tarball instead of a Git checkout. [native-inputs]: Remove field. [arguments]: Remove 'bootstrap' phase.
Diffstat (limited to 'gnu/packages/shells.scm')
-rw-r--r--gnu/packages/shells.scm22
1 files changed, 5 insertions, 17 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index 65e0eda50a..339faba05f 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -54,17 +54,12 @@
(version "0.5.9.1")
(source
(origin
- ;; The canonical source is offline, so we fetch the source code
- ;; from the Git repository. See:
- ;; https://www.mail-archive.com/dash@vger.kernel.org/msg01323.html
- (method git-fetch)
- (uri (git-reference
- (url "https://git.kernel.org/pub/scm/utils/dash/dash.git/")
- (commit (string-append "v" version))))
- (file-name (string-append name "-" version "-checkout"))
+ (method url-fetch)
+ (uri (string-append "http://gondor.apana.org.au/~herbert/dash/files/"
+ "dash-" version ".tar.gz"))
(sha256
(base32
- "0p01vx7rbyf5hyyaff7h8cbhq81bm5fmq1m933484lncl9rafcai"))
+ "0ng695mq5ngg43h7ljhxvbjm46ym3nayj6ssn47d2gm9fbm5pkay"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -75,17 +70,10 @@
"a command interpreter based on the original Bourne shell"))
#t))))
(build-system gnu-build-system)
- (native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)))
(inputs
`(("libedit" ,libedit)))
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (add-before 'configure 'bootstrap
- (lambda _ (zero? (system* "autoreconf" "-vfi")))))
- #:configure-flags '("--with-libedit")))
+ '(#:configure-flags '("--with-libedit")))
(home-page "http://gondor.apana.org.au/~herbert/dash")
(synopsis "POSIX-compliant shell optimised for size")
(description