summaryrefslogtreecommitdiff
path: root/gnu/packages/scheme.scm
diff options
context:
space:
mode:
authorFederico Beffa <beffa@fbengineering.ch>2016-10-17 09:05:39 +0200
committerFederico Beffa <beffa@fbengineering.ch>2016-10-19 08:44:11 +0200
commit13bbc0cc94902a9f442d8c594f3970afcf90bda5 (patch)
tree42ff5fe94188cf47dcf62eec3525cae2535bb2b3 /gnu/packages/scheme.scm
parentf7616df4afc1b1c81d722d3beae2ca6830065f6f (diff)
downloadgnu-guix-13bbc0cc94902a9f442d8c594f3970afcf90bda5.tar
gnu-guix-13bbc0cc94902a9f442d8c594f3970afcf90bda5.tar.gz
gnu: chez-scheme: Move to new module.
* gnu/packages/scheme.scm (chez-scheme, nanopass, stex): Move variables ... * gnu/packages/chez.scm (chez-scheme, nanopass, stex): ... here. New module. * gnu/local.mk (GNU_SYSTEM_MODULES): Add new file.
Diffstat (limited to 'gnu/packages/scheme.scm')
-rw-r--r--gnu/packages/scheme.scm161
1 files changed, 0 insertions, 161 deletions
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index 10368b2d15..41a7bf5328 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -591,167 +591,6 @@ an isolated heap allowing multiple VMs to run simultaneously in different OS
threads.")
(license bsd-3)))
-(define nanopass
- (let ((version "1.9"))
- (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/nanopass/nanopass-framework-scheme/archive"
- "/v" version ".tar.gz"))
- (sha256 (base32 "11pwyy4jiwhcl2am3a4ciczacjbjkyvdizqzdglb3l1hj2gj6nv2"))
- (file-name (string-append "nanopass-" version ".tar.gz")))))
-
-(define stex
- (let ((version "1.2.1"))
- (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/dybvig/stex/archive"
- "/v" version ".tar.gz"))
- (sha256 (base32 "03pl3f668h24dn51vccr1sj5lsba9zq3j37bnxjvdadcdaj4qy5z"))
- (file-name (string-append "stex-" version ".tar.gz")))))
-
-(define-public chez-scheme
- (package
- (name "chez-scheme")
- (version "9.4")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://github.com/cisco/ChezScheme/archive/"
- "v" version ".tar.gz"))
- (sha256
- (base32 "0lprmpsjg2plc6ykgkz482zyvhkzv6gd0vnar71ph21h6zknyklz"))
- (file-name (string-append "chez-scheme-" version ".tar.gz"))))
- (build-system gnu-build-system)
- (inputs
- `(("ncurses" ,ncurses)
- ("libx11" ,libx11)
- ("xorg-rgb" ,xorg-rgb)
- ("nanopass" ,nanopass)
- ("zlib" ,zlib)
- ("stex" ,stex)))
- (native-inputs
- `(("texlive" ,texlive)
- ("ghostscript" ,ghostscript-gs)
- ("netpbm" ,netpbm)))
- (native-search-paths
- (list (search-path-specification
- (variable "CHEZSCHEMELIBDIRS")
- (files (list (string-append "lib/csv" version "-site"))))))
- (outputs '("out" "doc"))
- (arguments
- `(#:modules ((guix build gnu-build-system)
- (guix build utils)
- (ice-9 match))
- #:test-target "test"
- #:configure-flags
- (list ,(match (or (%current-target-system) (%current-system))
- ("x86_64-linux" '(list "--machine=ta6le"))
- ("i686-linux" '(list "--machine=ti3le"))
- ;; FIXME: Some people succeeded in cross-compiling to
- ;; ARM. https://github.com/cisco/ChezScheme/issues/13
- (_
- '())))
- #:phases
- (modify-phases %standard-phases
- ;; Adapt the custom 'configure' script.
- (replace 'configure
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out"))
- (nanopass (assoc-ref inputs "nanopass"))
- (stex (assoc-ref inputs "stex"))
- (zlib (assoc-ref inputs "zlib"))
- (unpack (assoc-ref %standard-phases 'unpack))
- (patch-source-shebangs
- (assoc-ref %standard-phases 'patch-source-shebangs)))
- (map (match-lambda
- ((src orig-name new-name)
- (with-directory-excursion "."
- (apply unpack (list #:source src))
- (apply patch-source-shebangs (list #:source src)))
- (delete-file-recursively new-name)
- (system* "mv" orig-name new-name)))
- `((,nanopass "nanopass-framework-scheme-1.9" "nanopass")
- (,stex "stex-1.2.1" "stex")))
- ;; The Makefile wants to download and compile "zlib". We patch
- ;; it to use the one from our 'zlib' package.
- (substitute* "configure"
- (("rmdir zlib .*$") "echo \"using system zlib\"\n"))
- (substitute* (find-files "./c" "Mf-[a-zA-Z0-9.]+")
- (("\\$\\{Kernel\\}: \\$\\{kernelobj\\} \\.\\./zlib/libz\\.a")
- "${Kernel}: ${kernelobj}")
- (("ld ([-a-zA-Z0-9_${} ]+) \\.\\./zlib/libz\\.a" all args)
- (string-append "ld " args " " zlib "/lib/libz.a"))
- (("\\(cd \\.\\./zlib; ([-a-zA-Z0-9=./ ]+))")
- (which "true")))
- (substitute* (find-files "mats" "Mf-.*")
- (("^[[:space:]]+(cc ) *") "\tgcc "))
- (substitute*
- (find-files "." (string-append
- "("
- "Mf-[a-zA-Z0-9.]+"
- "|Makefile[a-zA-Z0-9.]*"
- "|checkin"
- "|stex\\.stex"
- "|newrelease"
- "|workarea"
- ;;"|[a-zA-Z0-9.]+\\.ms" ; guile can't read
- ")"))
- (("/bin/rm") (which "rm"))
- (("/bin/ln") (which "ln"))
- (("/bin/cp") (which "cp")))
- (substitute* "makefiles/installsh"
- (("/bin/true") (which "true")))
- (substitute* "stex/Makefile"
- (("PREFIX=/usr") (string-append "PREFIX=" out)))
- (zero? (system* "./configure" "--threads"
- (string-append "--installprefix=" out))))))
- ;; Installation of the documentation requires a running "chez".
- (add-after 'install 'install-doc
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((bin (string-append (assoc-ref outputs "out") "/bin"))
- (doc (string-append (assoc-ref outputs "doc")
- "/share/doc/" ,name "-" ,version)))
- (setenv "HOME" (getcwd))
- (setenv "PATH" (string-append (getenv "PATH") ":" bin))
- (with-directory-excursion "stex"
- (system* "make" (string-append "BIN=" bin)))
- (system* "make" "docs")
- (with-directory-excursion "csug"
- (substitute* "Makefile"
- (("/tmp/csug9") doc))
- (system* "make" "install")
- (install-file "csug.pdf" doc))
- (with-directory-excursion "release_notes"
- (install-file "release_notes.pdf" doc))
- #t)))
- ;; The binary file name is called "scheme" as the one from MIT/GNU
- ;; Scheme. We add a symlink to use in case both are installed.
- (add-after 'install 'install-symlink
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin"))
- (lib (string-append out "/lib"))
- (name "chez-scheme"))
- (symlink (string-append bin "/scheme")
- (string-append bin "/" name))
- (map (lambda (file)
- (symlink file (string-append (dirname file)
- "/" name ".boot")))
- (find-files lib "scheme.boot"))
- #t))))))
- ;; According to the documentation MIPS and ARM are not supported.
- (supported-systems '("x86_64-linux" "i686-linux"))
- (home-page "http://www.scheme.com")
- (synopsis "R6RS Scheme compiler and run-time")
- (description
- "Chez Scheme is a compiler and run-time system for the language of the
-Revised^6 Report on Scheme (R6RS), with numerous extensions. The compiler
-generates native code for each target processor, with support for x86, x86_64,
-and 32-bit PowerPC architectures.")
- (license asl2.0)))
-
(define-public scmutils
(let ()
(define (system-suffix)