summaryrefslogtreecommitdiff
path: root/gnu/packages/scanner.scm
diff options
context:
space:
mode:
authorAndy Patterson <ajpatter@uwaterloo.ca>2016-12-14 00:03:24 -0500
committerLudovic Courtès <ludo@gnu.org>2016-12-17 23:13:04 +0100
commit32aa37a2e7a5653915a5c1b1fdef7f726ceaf5d2 (patch)
tree0838988babe54fcc69bedcdcefdca94a01c8e111 /gnu/packages/scanner.scm
parent33a14e29f9a19c9e4e76bbba73e21e22d4bab0b9 (diff)
downloadgnu-guix-32aa37a2e7a5653915a5c1b1fdef7f726ceaf5d2.tar
gnu-guix-32aa37a2e7a5653915a5c1b1fdef7f726ceaf5d2.tar.gz
gnu: Add and use sane-backends-minimal.
* gnu/packages/scanner.scm (sane-backends): Rename to... (sane-backends-minimal): this. Adjust name, source, synopsis and description accordingly. * gnu/packages/cups.scm (hplip): Use 'sane-backends-minimal' instead of 'sane-backends'. * gnu/packages/gnome.scm (colord, simple-scan): Likewise. * gnu/packages/libreoffice.scm (libreoffice): Likewise. * gnu/packages/wine.scm (wine): Likewise. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/scanner.scm')
-rw-r--r--gnu/packages/scanner.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/scanner.scm b/gnu/packages/scanner.scm
index 01db5ee210..e913858f51 100644
--- a/gnu/packages/scanner.scm
+++ b/gnu/packages/scanner.scm
@@ -26,15 +26,15 @@
#:use-module ((guix licenses)
#:prefix licence:))
-(define-public sane-backends
+(define-public sane-backends-minimal
(package
- (name "sane-backends")
+ (name "sane-backends-minimal")
(version "1.0.25")
(source (origin
(method url-fetch)
(uri (string-append
"https://alioth.debian.org/frs/download.php/file/4146/"
- name "-" version ".tar.gz"))
+ "sane-backends-" version ".tar.gz"))
(sha256
(base32
"0b3fvhrxl4l82bf3v0j47ypjv6a0k5lqbgknrq1agpmjca6vmmx4"))))
@@ -71,9 +71,10 @@
;; **** File generated for html-backends-split mode is different from reference
;; Makefile:501: recipe for target 'check.local' failed
(home-page "http://www.sane-project.org")
- (synopsis "Raster image scanner library and drivers")
+ (synopsis
+ "Raster image scanner library and drivers, without scanner support")
(description "SANE stands for \"Scanner Access Now Easy\" and is an API
proving access to any raster image scanner hardware (flatbed scanner,
hand-held scanner, video- and still-cameras, frame-grabbers, etc.). The
-package contains the library and drivers.")
+package contains the library, but no drivers.")
(license licence:gpl2+))) ; plus linking exception