summaryrefslogtreecommitdiff
path: root/gnu/packages/rust.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-05-10 00:27:17 +0200
committerLudovic Courtès <ludo@gnu.org>2018-05-10 00:27:17 +0200
commitafc2bf53066975558676bc7f4957ad85d0ec170a (patch)
treef6ebfaca2a3e5562e138a78ffe964ff3f44ecab7 /gnu/packages/rust.scm
parent62834314434323e5250f9d99b35d523ca216b540 (diff)
downloadgnu-guix-afc2bf53066975558676bc7f4957ad85d0ec170a.tar
gnu-guix-afc2bf53066975558676bc7f4957ad85d0ec170a.tar.gz
gnu: rust: Do not refer to 'gcc' from the top level.
Fixes <https://bugs.gnu.org/31392>. Reported by Marius Bakke <mbakke@fastmail.com>. * gnu/packages/rust.scm (rust-1.19)[native-search-paths]: Avoid top-level reference to 'gcc', which could lead to unbound variable errors.
Diffstat (limited to 'gnu/packages/rust.scm')
-rw-r--r--gnu/packages/rust.scm15
1 files changed, 14 insertions, 1 deletions
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index 0a9d5bb382..bf50cdd55e 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -237,8 +237,21 @@ in turn be used to build the final Rust.")
("llvm" ,llvm-3.9.1)
("openssl" ,openssl)
("libcurl" ,curl))) ; For "cargo"
+
;; rustc invokes gcc, so we need to set its search paths accordingly.
- (native-search-paths (package-native-search-paths gcc))
+ ;; Note: duplicate its value here to cope with circular dependencies among
+ ;; modules (see <https://bugs.gnu.org/31392>).
+ (native-search-paths
+ (list (search-path-specification
+ (variable "C_INCLUDE_PATH")
+ (files '("include")))
+ (search-path-specification
+ (variable "CPLUS_INCLUDE_PATH")
+ (files '("include")))
+ (search-path-specification
+ (variable "LIBRARY_PATH")
+ (files '("lib" "lib64")))))
+
(synopsis "Compiler for the Rust progamming language")
(description "Rust is a systems programming language that provides memory
safety and thread safety guarantees.")