summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-08-26 14:11:13 +0200
committerJulien Lepiller <julien@lepiller.eu>2018-09-01 23:08:02 +0200
commitceac6f6f5bca77d541f793b2825d9de401be8aa6 (patch)
tree7bf02e826eec823032d625bef850bef99c23eb33 /gnu/packages/ruby.scm
parent88ed727fc5513ffbb87cba52604d0689939f3b3d (diff)
downloadgnu-guix-ceac6f6f5bca77d541f793b2825d9de401be8aa6.tar
gnu-guix-ceac6f6f5bca77d541f793b2825d9de401be8aa6.tar.gz
gnu: Add ruby-jekyll-watch.
* gnu/packages/ruby.scm (ruby-jekyll-watch): New variable.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index a21e1fea9a..58cd6fc6d7 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5383,3 +5383,25 @@ features that don't exist yet like variables, nesting, mixins and inheritance.")
(description "This gem provide built-in support for the Sass converter
in Jekyll.")
(license license:expat)))
+
+(define-public ruby-jekyll-watch
+ (package
+ (name "ruby-jekyll-watch")
+ (version "2.0.0")
+ (source (origin
+ (method url-fetch)
+ (uri (rubygems-uri "jekyll-watch" version))
+ (sha256
+ (base32
+ "0m7scvj3ki8bmyx5v8pzibpg6my10nycnc28lip98dskf8iakprp"))))
+ (build-system ruby-build-system)
+ (propagated-inputs
+ `(("ruby-listen-3.0" ,ruby-listen-3.0)))
+ (arguments
+ ;; No rakefile
+ `(#:tests? #f))
+ (home-page "https://github.com/jekyll/jekyll-watch")
+ (synopsis "Jekyll auto-rebuild support")
+ (description "This gems add the @code{--watch} switch to the jekyll CLI
+interface. It allows Jekyll to rebuild your site when a file changes.")
+ (license license:expat)))