summaryrefslogtreecommitdiff
path: root/gnu/packages/ruby.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-08-26 15:35:36 +0200
committerJulien Lepiller <julien@lepiller.eu>2018-09-01 23:08:27 +0200
commitabbe629c6a25bea320e49163fff71d33521bb127 (patch)
tree81fd8ebb0d70ded33d55972ed7ffba1c2336074c /gnu/packages/ruby.scm
parent00d71efca6be6bff7e2bb0f5a61ae8a7929af39a (diff)
downloadgnu-guix-abbe629c6a25bea320e49163fff71d33521bb127.tar
gnu-guix-abbe629c6a25bea320e49163fff71d33521bb127.tar.gz
gnu: Add ruby-pdf-reader.
* gnu/packages/ruby.scm (ruby-pdf-reader): New variable.
Diffstat (limited to 'gnu/packages/ruby.scm')
-rw-r--r--gnu/packages/ruby.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 93ed29443e..86b00ef8ae 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5465,3 +5465,33 @@ checks over your ruby project as part of continuous integration build. It
comes with a few checks out of the box, but also provides an API for loading
custom checks. This gem provides a set of additional checks.")
(license license:expat)))
+
+(define-public ruby-pdf-reader
+ (package
+ (name "ruby-pdf-reader")
+ (version "2.1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (rubygems-uri "pdf-reader" version))
+ (sha256
+ (base32
+ "1b3ig4wpcgdbqa7yw0ahwbmikkkywn2a22bfmrknl5ls7g066x45"))))
+ (build-system ruby-build-system)
+ (arguments `(#:test-target "spec"))
+ (native-inputs
+ `(("bundler" ,bundler)
+ ("ruby-rspec" ,ruby-rspec)
+ ("ruby-cane" ,ruby-cane)
+ ("ruby-morecane" ,ruby-morecane)))
+ (propagated-inputs
+ `(("ruby-afm" ,ruby-afm)
+ ("ruby-ascii85" ,ruby-ascii85)
+ ("ruby-hashery" ,ruby-hashery)
+ ("ruby-rc4" ,ruby-rc4)
+ ("ruby-ttfunk" ,ruby-ttfunk)))
+ (home-page "https://github.com/yob/pdf-reader")
+ (synopsis "PDF parser in Ruby")
+ (description "The PDF::Reader library implements a PDF parser conforming as
+much as possible to the PDF specification from Adobe. It provides programmatic
+access to the contents of a PDF file with a high degree of flexibility.")
+ (license license:gpl3+)))