summaryrefslogtreecommitdiff
path: root/gnu/packages/rdesktop.scm
diff options
context:
space:
mode:
authorThomas Danckaert <thomas.danckaert@gmail.com>2017-08-16 21:49:17 +0200
committerThomas Danckaert <thomas.danckaert@gmail.com>2017-08-18 14:52:35 +0200
commitcc81f1c3495e81cc738b486e1ef2b4a1dbe99e28 (patch)
treefecb3fa97b6300fed20fc2de81e8ea327a65fe76 /gnu/packages/rdesktop.scm
parentc5a856d5516673c7a40c916aeb7572c4eadbede6 (diff)
downloadgnu-guix-cc81f1c3495e81cc738b486e1ef2b4a1dbe99e28.tar
gnu-guix-cc81f1c3495e81cc738b486e1ef2b4a1dbe99e28.tar.gz
gnu: freerdp: Revert to version 1.1.
* gnu/packages/rdesktop.scm (freerdp) [version, source]: Revert to upstream branch 1.1. [inputs]: Use ffmpeg-2.8. * gnu/packages/gnome.scm (vinagre): Add patches required to build against freerdp branch 1.1. * gnu/packages/patches/vinagre-revert-1.patch, gnu/packages/patches/vinagre-revert-2.patch: New files. * gnu/local.mk (dist_patch_DATA): Add them.
Diffstat (limited to 'gnu/packages/rdesktop.scm')
-rw-r--r--gnu/packages/rdesktop.scm95
1 files changed, 49 insertions, 46 deletions
diff --git a/gnu/packages/rdesktop.scm b/gnu/packages/rdesktop.scm
index 7946cde790..7c2b8911b7 100644
--- a/gnu/packages/rdesktop.scm
+++ b/gnu/packages/rdesktop.scm
@@ -70,51 +70,54 @@ to remotely control a user's Windows desktop.")
(license license:gpl3+)))
(define-public freerdp
- (package
- (name "freerdp")
- (version "2.0.0-rc0")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/FreeRDP/FreeRDP/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32 "0r36zwhl7fhmdng5pvl2a106gqbcqq184g2i2klz6ilna8pxjcml"))))
- (build-system cmake-build-system)
- (native-inputs
- `(("pkg-config" ,pkg-config)
- ("xmlto" ,xmlto)))
- (inputs
- `(("libx11" ,libx11)
- ("libxkbfile" ,libxkbfile)
- ("libxcursor" ,libxcursor)
- ("libxext" ,libxext)
- ("libxi" ,libxi)
- ("libxv" ,libxv)
- ("libxrandr" ,libxrandr)
- ("libxrender" ,libxrender)
- ("libxinerama" ,libxinerama)
- ("libxshmfence" ,libxshmfence)
- ("libxml2" ,libxml2)
- ("libxslt" ,libxslt)
- ("cups" ,cups)
- ("ffmpeg" ,ffmpeg)
- ("pulseaudio" ,pulseaudio)
- ("alsa-lib" ,alsa-lib)
- ("gstreamer" ,gstreamer)
- ("gst-plugins-base" ,gst-plugins-base)
- ("zlib" ,zlib)
- ("openssl" ,openssl)))
- (arguments
- `(#:configure-flags
- '("-DCMAKE_INSTALL_LIBDIR=lib"
- "-DWITH_PULSE=ON"
- "-DWITH_CUPS=ON")
- #:tests? #f)) ; no 'test' target
- (home-page "https://www.freerdp.com")
- (synopsis "Remote Desktop Protocol implementation")
- (description "FreeRDP implements Microsoft's Remote Desktop Protocol. It
-consists of the @code{xfreerdp} client, libraries for client and server
+ (let ((commit "03ab68318966c3a22935a02838daaea7b7fbe96c"))
+ (package
+ (name "freerdp")
+ (version (git-version "1.1" "1" commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ ;; We need the 1.1 branch for RDP support in vinagre.
+ (url "git://github.com/FreeRDP/FreeRDP.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "07ish8rmvbk2zd99k91qybmmh5h4afly75l5kbvslhq1r6k8pbmp"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("xmlto" ,xmlto)))
+ (inputs
+ `(("libx11" ,libx11)
+ ("libxkbfile" ,libxkbfile)
+ ("libxcursor" ,libxcursor)
+ ("libxext" ,libxext)
+ ("libxi" ,libxi)
+ ("libxv" ,libxv)
+ ("libxrandr" ,libxrandr)
+ ("libxrender" ,libxrender)
+ ("libxinerama" ,libxinerama)
+ ("libxshmfence" ,libxshmfence)
+ ("libxml2" ,libxml2)
+ ("libxslt" ,libxslt)
+ ("cups" ,cups)
+ ("ffmpeg" ,ffmpeg-2.8)
+ ("pulseaudio" ,pulseaudio)
+ ("alsa-lib" ,alsa-lib)
+ ("gstreamer" ,gstreamer)
+ ("gst-plugins-base" ,gst-plugins-base)
+ ("zlib" ,zlib)
+ ("openssl" ,openssl)))
+ (arguments
+ `(#:configure-flags
+ '("-DCMAKE_INSTALL_LIBDIR=lib"
+ "-DWITH_PULSE=ON"
+ "-DWITH_CUPS=ON")
+ #:tests? #f)) ; no 'test' target
+ (home-page "https://www.freerdp.com")
+ (synopsis "Remote Desktop Protocol implementation")
+ (description "FreeRDP implements Microsoft's Remote Desktop Protocol.
+It consists of the @code{xfreerdp} client, libraries for client and server
functionality, and Windows Portable Runtime (WinPR), a portable implementation
of parts of the Windows API.")
- (license license:asl2.0)))
+ (license license:asl2.0))))