summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-07-04 16:03:28 +0300
committerEfraim Flashner <efraim@flashner.co.il>2018-07-11 11:08:48 +0300
commitf79c7e9747d941a5baa7ef3d881ad1a48eca6c1a (patch)
tree44ea08f2401e43f4bb8bcfc1f5ca4f0aa94849be /gnu/packages/qt.scm
parent64a64fa72a2f9858bc149e1a00ba9f89e8f58086 (diff)
downloadgnu-guix-f79c7e9747d941a5baa7ef3d881ad1a48eca6c1a.tar
gnu-guix-f79c7e9747d941a5baa7ef3d881ad1a48eca6c1a.tar.gz
gnu: qt: Update to 5.11.1.
* gnu/packages/qt.scm (qt): Update to 5.11.1. [source]: Update snippet. [inputs]: Remove sqlite. [arguments]: Don't use system sqlite.
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm25
1 files changed, 19 insertions, 6 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 0f01df226b..000c5fb02f 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -105,7 +105,7 @@ system, and the core design of Django is reused in Grantlee.")
(define-public qt
(package
(name "qt")
- (version "5.9.4")
+ (version "5.11.1")
(outputs '("out" "examples"))
(source (origin
(method url-fetch)
@@ -114,11 +114,11 @@ system, and the core design of Django is reused in Grantlee.")
"http://download.qt.io/official_releases/qt/"
(version-major+minor version)
"/" version
- "/single/qt-everywhere-opensource-src-"
+ "/single/qt-everywhere-src-"
version ".tar.xz"))
(sha256
(base32
- "1mblh8k04l13nk9fhhrr43h5bcph1gbz94j5y7csx8zvxb5xkb73"))
+ "0azva1wx298jh0xskymz8jic83yhxs1xfxf321wqd5lwiyq2qq1r"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -135,7 +135,7 @@ system, and the core design of Django is reused in Grantlee.")
(lambda (dir)
(delete-file-recursively (string-append "qtbase/src/3rdparty/" dir)))
(list "double-conversion" "freetype" "harfbuzz-ng"
- "libpng" "libjpeg" "pcre2" "sqlite" "xcb"
+ "libpng" "libjpeg" "pcre2" "xcb"
"xkbcommon" "zlib"))
(for-each
(lambda (dir)
@@ -143,10 +143,23 @@ system, and the core design of Django is reused in Grantlee.")
(list "qtimageformats/src/3rdparty"
"qtmultimedia/examples/multimedia/spectrum/3rdparty"
"qtwayland/examples"
+ "qtscxml/tests/3rdparty"
"qtcanvas3d/examples/canvas3d/3rdparty"))
;; Tests depend on this example, which depends on the 3rd party code.
(substitute* "qtmultimedia/examples/multimedia/multimedia.pro"
(("spectrum") "#"))
+ (substitute* "qtxmlpatterns/tests/auto/auto.pro"
+ (("qxmlquery") "# qxmlquery")
+ (("xmlpatterns ") "# xmlpatterns"))
+ (substitute* "qtwebglplugin/tests/plugins/platforms/platforms.pro"
+ (("webgl") "# webgl"))
+ (substitute* "qtscxml/tests/auto/auto.pro"
+ (("scion") "#"))
+ (substitute* "qtnetworkauth/tests/auto/auto.pro"
+ (("oauth1 ") "# oauth1 "))
+ (substitute* "qtremoteobjects/tests/auto/qml/qml.pro"
+ (("integration") "# integration")
+ (("usertypes") "# usertypes"))
#t))))
(build-system gnu-build-system)
(propagated-inputs
@@ -193,7 +206,7 @@ system, and the core design of Django is reused in Grantlee.")
("postgresql" ,postgresql)
("pulseaudio" ,pulseaudio)
("pcre2" ,pcre2)
- ("sqlite" ,sqlite)
+ ;("sqlite" ,sqlite)
("udev" ,eudev)
("unixodbc" ,unixodbc)
("wayland" ,wayland)
@@ -244,7 +257,7 @@ system, and the core design of Django is reused in Grantlee.")
"-no-compile-examples"
;; Most "-system-..." are automatic, but some use
;; the bundled copy by default.
- "-system-sqlite"
+ ;"-system-sqlite"
"-system-harfbuzz"
;; explicitly link with openssl instead of dlopening it
"-openssl-linked"