summaryrefslogtreecommitdiff
path: root/gnu/packages/qt.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-07-04 16:06:05 +0300
committerEfraim Flashner <efraim@flashner.co.il>2018-07-11 11:08:48 +0300
commita01a3763fc20a8c8ae31174fdbf0271bed0bbc5b (patch)
tree43114a96280f62905253b750d6951499b0c408ee /gnu/packages/qt.scm
parente3232b2627644734deb26f51eaeaee8e185cc919 (diff)
downloadgnu-guix-a01a3763fc20a8c8ae31174fdbf0271bed0bbc5b.tar
gnu-guix-a01a3763fc20a8c8ae31174fdbf0271bed0bbc5b.tar.gz
gnu: python-pyqt: Update to 5.11.2.
* gnu/packages/qt.scm (python-pyqt): Update to 5.11.2. [arguments]: Substitute INVOKE for SYSTEM*. (python2-pyqt)[inputs]: Add python2-enum34.
Diffstat (limited to 'gnu/packages/qt.scm')
-rw-r--r--gnu/packages/qt.scm29
1 files changed, 15 insertions, 14 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 47e07912e4..198d719bc2 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1660,7 +1660,7 @@ module provides support functions to the automatically generated code.")
(define-public python-pyqt
(package
(name "python-pyqt")
- (version "5.10.1")
+ (version "5.11.2")
(source
(origin
(method url-fetch)
@@ -1670,7 +1670,7 @@ module provides support functions to the automatically generated code.")
version ".tar.gz"))
(sha256
(base32
- "1vz9c4v0k8azk2b08swwybrshzw32x8djjpq13mf9v15x1qyjclr"))
+ "00wn9svgyp0fsrkc4ma15zcxg31pw4gsgaz6nwb3fhy3al8miakw"))
(patches (search-patches "pyqt-configure.patch"))))
(build-system gnu-build-system)
(native-inputs
@@ -1717,18 +1717,18 @@ module provides support functions to the automatically generated code.")
python-major+minor
"/site-packages"))
(stubs (string-append lib "/PyQt5")))
- (zero? (system* "python" "configure.py"
- "--confirm-license"
- "--bindir" bin
- "--destdir" lib
- "--designer-plugindir" designer
- "--qml-plugindir" qml
- ; Where to install the PEP 484 Type Hints stub
- ; files. Without this the stubs are tried to be
- ; installed into the python package's
- ; site-package directory, which is read-only.
- "--stubsdir" stubs
- "--sipdir" sip))))))))
+ (invoke "python" "configure.py"
+ "--confirm-license"
+ "--bindir" bin
+ "--destdir" lib
+ "--designer-plugindir" designer
+ "--qml-plugindir" qml
+ ; Where to install the PEP 484 Type Hints stub
+ ; files. Without this the stubs are tried to be
+ ; installed into the python package's
+ ; site-package directory, which is read-only.
+ "--stubsdir" stubs
+ "--sipdir" sip)))))))
(home-page "https://www.riverbankcomputing.com/software/pyqt/intro")
(synopsis "Python bindings for Qt")
(description
@@ -1745,6 +1745,7 @@ contain over 620 classes.")
("qtbase" ,qtbase)))
(inputs
`(("python" ,python-2)
+ ("python2-enum34" ,python2-enum34)
,@(alist-delete "python" (package-inputs python-pyqt))))))
(define-public python-pyqt-4