summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2015-11-23 23:46:09 -0500
committerDavid Thompson <dthompson2@worcester.edu>2015-12-05 09:44:37 -0500
commitb5f218be26d8a4f683bcece76ac10314cb58b326 (patch)
treef3a45c93129020fd1f50544ab6fe340718d78453 /gnu/packages/python.scm
parent44298269baae6cb8bbaa19e504f391c74cf5729b (diff)
downloadgnu-guix-b5f218be26d8a4f683bcece76ac10314cb58b326.tar
gnu-guix-b5f218be26d8a4f683bcece76ac10314cb58b326.tar.gz
gnu: Add python2-pythondialog.
* gnu/packages/python.scm (python2-pythondialog): New variable.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 4e69e74b9d..05de9939fb 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6342,6 +6342,43 @@ facilities for defining, registering and looking up components.")
(define-public python2-zope-component
(package-with-python2 python-zope-component))
+(define-public python2-pythondialog
+ (package
+ (name "python2-pythondialog")
+ (version "3.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://pypi.python.org/packages/source/p/"
+ "python2-pythondialog/python2-pythondialog-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1yhkagsh99bfi592ymczf8rnw8rk6n9hdqy3dd98m3yrx8zmjvry"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let* ((dialog (assoc-ref inputs "dialog")))
+ ;; Since this library really wants to grovel the search path, we
+ ;; must hardcode dialog's store path into it.
+ (substitute* "dialog.py"
+ (("os.getenv\\(\"PATH\", \":/bin:/usr/bin\"\\)")
+ (string-append "os.getenv(\"PATH\") + \":" dialog "/bin\"")))
+ #t))))
+ #:python ,python-2
+ #:tests? #f)) ; no test suite
+ (propagated-inputs
+ `(("dialog" ,dialog)))
+ (home-page "http://pythondialog.sourceforge.net/")
+ (synopsis "Python interface to the UNIX dialog utility")
+ (description "A Python wrapper for the dialog utility. Its purpose is to
+provide an easy to use, pythonic and comprehensive Python interface to dialog.
+This allows one to make simple text-mode user interfaces on Unix-like systems")
+ (license lgpl2.1)))
+
(define-public python-pyrfc3339
(package
(name "python-pyrfc3339")