summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2015-11-08 15:38:55 -0500
committerDavid Thompson <dthompson2@worcester.edu>2015-12-05 09:44:37 -0500
commit99fffa8ae08264b1c41ddaa9e7f745dcb621b398 (patch)
tree3e066921a52d86c668f92531fbad601c85125ae2 /gnu/packages/python.scm
parent5eea20051877044fd4d2fa2ea075d5f66824f123 (diff)
downloadgnu-guix-99fffa8ae08264b1c41ddaa9e7f745dcb621b398.tar
gnu-guix-99fffa8ae08264b1c41ddaa9e7f745dcb621b398.tar.gz
gnu: Add python-configobj.
* gnu/packages/python.scm (python-configobj, python2-configobj): New variables. * gnu/packages/patches/python-configobj-setuptools.patch: New file. * gnu-system.am (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index d2d6b91138..4e69e74b9d 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6396,3 +6396,33 @@ addon modules.")
(define-public python2-werkzeug
(package-with-python2 python-werkzeug))
+
+(define-public python-configobj
+ (package
+ (name "python-configobj")
+ (version "5.0.6")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://pypi.python.org/packages/source/c/configobj/"
+ "configobj-" version ".tar.gz"))
+ (sha256
+ (base32
+ "00h9rcmws03xvdlfni11yb60bz3kxfvsj6dg6nrpzj71f03nbxd2"))
+ ;; Patch setup.py so it looks for python-setuptools, which is
+ ;; required to parse the keyword 'install_requires' in setup.py.
+ (patches (list (search-patch "python-configobj-setuptools.patch")))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-setuptools" ,python-setuptools)
+ ("python-six" ,python-six)))
+ (synopsis "Config file reading, writing and validation")
+ (description "ConfigObj is a simple but powerful config file reader and
+writer: an ini file round tripper. Its main feature is that it is very easy to
+use, with a straightforward programmer’s interface and a simple syntax for
+config files.")
+ (home-page "https://github.com/DiffSK/configobj")
+ (license bsd-3)))
+
+(define-public python2-configobj
+ (package-with-python2 python-configobj))