summaryrefslogtreecommitdiff
path: root/gnu/packages/python.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-10-23 16:56:57 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-10-23 17:11:03 +0200
commit0c8e255549760e83c4acf08747047449ec952113 (patch)
tree2e8ccd2660185d368afc1c82875df82b87ecaac2 /gnu/packages/python.scm
parent5176795d22860c18015e36b7a9d3b8729b6729f1 (diff)
downloadgnu-guix-0c8e255549760e83c4acf08747047449ec952113.tar
gnu-guix-0c8e255549760e83c4acf08747047449ec952113.tar.gz
gnu: python-attrs: Update to 18.2.0.
* gnu/packages/python.scm (python-attrs): Update to 18.2.0. [arguments]: New field. [native-inputs]: Add PYTHON-PYMPLER. (python-attrs-bootstrap): Stay on version 17.4.0.
Diffstat (limited to 'gnu/packages/python.scm')
-rw-r--r--gnu/packages/python.scm32
1 files changed, 30 insertions, 2 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 42097b889c..59ef5c2ca3 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -11122,17 +11122,36 @@ and bit flag values.")
(define-public python-attrs
(package
(name "python-attrs")
- (version "17.4.0")
+ (version "18.2.0")
(source (origin
(method url-fetch)
(uri (pypi-uri "attrs" version))
(sha256
(base32
- "1jafnn1kzd6qhxgprhx6y6ik1r5m2rilx25syzcmq03azp660y8w"))))
+ "0s9ydh058wmmf5v391pym877x4ahxg45dw6a0w4c7s5wgpigdjqh"))))
(build-system python-build-system)
+ (arguments
+ `(#:modules ((guix build utils)
+ (guix build python-build-system)
+ (ice-9 ftw)
+ (srfi srfi-1)
+ (srfi srfi-26))
+ #:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (let ((cwd (getcwd)))
+ (setenv "PYTHONPATH"
+ (string-append
+ cwd "/build/"
+ (find (cut string-prefix? "lib" <>)
+ (scandir (string-append cwd "/build")))
+ ":"
+ (getenv "PYTHONPATH")))
+ (invoke "python" "-m" "pytest")))))))
(native-inputs
`(("python-coverage" ,python-coverage)
("python-hypothesis" ,python-hypothesis)
+ ("python-pympler" ,python-pympler)
("python-pytest" ,python-pytest)
("python-six" ,python-six)
("python-sphinx" ,python-sphinx)
@@ -11151,6 +11170,15 @@ protocols.")
(package
(inherit python-attrs)
(name "python-attrs-bootstrap")
+ ;; Keep this on a fixed version so python-attrs can be updated without
+ ;; triggering a mass-rebuild. FIXME: Update this in the next rebuild cycle.
+ (version "17.4.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "attrs" version))
+ (sha256
+ (base32
+ "1jafnn1kzd6qhxgprhx6y6ik1r5m2rilx25syzcmq03azp660y8w"))))
(native-inputs `())
(arguments `(#:tests? #f))))