summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-10-27 20:37:07 +0100
committerChristopher Baines <mail@cbaines.net>2018-11-20 19:48:00 +0000
commit90b9c5adea950c7daff3ab14e69601dc78803d6d (patch)
tree59c39e9d7e51bf0676aef9334ecef4cd56b935f7 /gnu/packages/python-web.scm
parentb3175c709d7fb2e8519902c3dd66608436d0f0ff (diff)
downloadgnu-guix-90b9c5adea950c7daff3ab14e69601dc78803d6d.tar
gnu-guix-90b9c5adea950c7daff3ab14e69601dc78803d6d.tar.gz
gnu: Add python-jsmin.
* gnu/packages/python-web.scm (python-jsmin, python2-jsmin): New variables.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index eda796e01c..161fe6eac2 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -2168,6 +2168,25 @@ It comes with safe defaults and easily configurable options.")
(define-public python2-flask-htmlmin
(package-with-python2 python-flask-htmlmin))
+(define-public python-jsmin
+ (package
+ (name "python-jsmin")
+ (version "2.2.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "jsmin" version))
+ (sha256
+ (base32
+ "0fsmqbjvpxvff0984x7c0y8xmf49ax9mncz48b9xjx8wrnr9kpxn"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/tikitu/jsmin/")
+ (synopsis "Python JavaScript minifier")
+ (description
+ "@code{jsmin} is a JavaScript minifier, usable from both Python code and
+on the command line.")
+ (license license:expat)))
+
(define-public python-flask-login
(package
(name "python-flask-login")