summaryrefslogtreecommitdiff
path: root/gnu/packages/python-web.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-09-10 18:01:51 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-09-10 18:21:59 +0200
commit7c8b1bf66448d072be67682ed3ce618da831f72f (patch)
treea48e5a2fa054bdc02a6c3806107bd1dfd9a3a98e /gnu/packages/python-web.scm
parent83397e07862198cf3145112c8100fd8dd142fd21 (diff)
downloadgnu-guix-7c8b1bf66448d072be67682ed3ce618da831f72f.tar
gnu-guix-7c8b1bf66448d072be67682ed3ce618da831f72f.tar.gz
gnu: python-genshi: Update to 0.7.1.
* gnu/packages/python-web.scm (python-genshi): Update to 0.7.1. [source]: Use GIT-FETCH and GIT-FILE-NAME. Remove patches. * gnu/packages/patches/python-genshi-add-support-for-python-3.4-AST.patch, gnu/packages/patches/python-genshi-buildable-on-python-2.7.patch, gnu/packages/patches/python-genshi-disable-speedups-on-python-3.3.patch, gnu/packages/patches/python-genshi-fix-tests-on-python-3.5.patch, gnu/packages/patches/python-genshi-isstring-helper.patch, gnu/packages/patches/python-genshi-stripping-of-unsafe-script-tags.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Remove them.
Diffstat (limited to 'gnu/packages/python-web.scm')
-rw-r--r--gnu/packages/python-web.scm31
1 files changed, 8 insertions, 23 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 9008ca5e72..226b9b631b 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -45,6 +45,7 @@
(define-module (gnu packages python-web)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix build-system python)
#:use-module (guix utils)
#:use-module (gnu packages)
@@ -2248,29 +2249,16 @@ for Flask programs that are using @code{python-alembic}.")
(define-public python-genshi
(package
(name "python-genshi")
- (version "0.7")
+ (version "0.7.1")
(source
(origin
- (method url-fetch)
- (uri (string-append
- "https://ftp.edgewall.org/pub/genshi/Genshi-"
- version ".tar.gz"))
- (patches
- (search-patches
- ;; The first 4 patches are in the master branch upstream.
- ;; See this as a reference https://genshi.edgewall.org/ticket/582
- ;; The last 2 are NOT in any branch.
- ;; They were sent as attachments to a ticket opened at
- ;; https://genshi.edgewall.org/ticket/602#no1
- "python-genshi-stripping-of-unsafe-script-tags.patch"
- "python-genshi-disable-speedups-on-python-3.3.patch"
- "python-genshi-isstring-helper.patch"
- "python-genshi-add-support-for-python-3.4-AST.patch"
- "python-genshi-fix-tests-on-python-3.5.patch"
- "python-genshi-buildable-on-python-2.7.patch"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/edgewall/genshi.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "0lkkbp6fbwzv0zda5iqc21rr7rdldkwh3hfabfjl9i4bwq14858x"))))
+ (base32 "01fx8fnpay5w048ppyjivg2dgfpp5rybn07y3pfsgj2knram3nhl"))))
(build-system python-build-system)
(home-page "https://genshi.edgewall.org/")
(synopsis "Toolkit for generation of output for the web")
@@ -2279,9 +2267,6 @@ of components for parsing, generating, and processing HTML, XML or other
textual content for output generation on the web.")
(license license:bsd-3)))
-;; The linter here claims that patch file names should start with the package
-;; name. But, in this case the patches are inherited from python-genshi with
-;; the "python-genshi-" prefix instead of "python2-genshi-".
(define-public python2-genshi
(package-with-python2 python-genshi))