summaryrefslogtreecommitdiff
path: root/gnu/packages/php.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-02-27 11:15:29 +0100
committerLeo Famulari <leo@famulari.name>2017-03-03 14:12:31 -0500
commit60a5080675e3787c51b6cd61d43c610f85e4028a (patch)
treee717311f60285a9b4da2f557a6f491b7a9f618ac /gnu/packages/php.scm
parente8293ef12cd3df77f4111163fa5ac554480d134b (diff)
downloadgnu-guix-60a5080675e3787c51b6cd61d43c610f85e4028a.tar
gnu-guix-60a5080675e3787c51b6cd61d43c610f85e4028a.tar.gz
gnu: php: Update to 7.1.2.
* gnu/packages/php.scm (php): Update to 7.1.2. [inputs]: Add gnutls. [arguments]: Disable more tests in 'prepare-tests' phase. (gd-for-php): Remove variable. * gnu/packages/patches/gd-fix-chunk-size-on-boundaries.patch, gnu/packages/patches/gd-fix-truecolor-format-correction.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Remove them. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/php.scm')
-rw-r--r--gnu/packages/php.scm27
1 files changed, 13 insertions, 14 deletions
diff --git a/gnu/packages/php.scm b/gnu/packages/php.scm
index 16b098517a..0dfee36c1b 100644
--- a/gnu/packages/php.scm
+++ b/gnu/packages/php.scm
@@ -50,21 +50,10 @@
#:use-module (guix build-system gnu)
#:use-module ((guix licenses) #:prefix license:))
-;; This fixes PHP bugs 73155 and 73159. Remove when gd
-;; is updated to > 2.2.3.
-(define gd-for-php
- (package (inherit gd)
- (source
- (origin
- (inherit (package-source gd))
- (patches (search-patches
- "gd-fix-truecolor-format-correction.patch"
- "gd-fix-chunk-size-on-boundaries.patch"))))))
-
(define-public php
(package
(name "php")
- (version "7.0.14")
+ (version "7.1.2")
(home-page "https://secure.php.net/")
(source (origin
(method url-fetch)
@@ -72,7 +61,7 @@
name "-" version ".tar.xz"))
(sha256
(base32
- "12ccgbrfchgvmcfb88rcknq7xmrf19c5ysdr4v8jxk51j9izy78g"))
+ "0wg9ng230w724rpwsrhcg4pw41xm1xhz0zx76haanyymkz1s05fq"))
(modules '((guix build utils)))
(snippet
'(with-directory-excursion "ext"
@@ -179,6 +168,13 @@
"ext/standard/tests/general_functions/bug44667.phpt"
"ext/standard/tests/general_functions/proc_open.phpt")
(("/bin/cat") (which "cat")))
+
+ ;; These tests fail because they include a file whose modification
+ ;; time is 0. Touch them to make the test pass. The issue is reported
+ ;; upstream as #74137.
+ (utime "sapi/phpdbg/tests/include.inc" 1 1)
+ (utime "sapi/phpdbg/tests/phpdbg_get_executable_stream_wrapper.inc" 1 1)
+
;; The encoding of this file is not recognized, so we simply drop it.
(delete-file "ext/mbstring/tests/mb_send_mail07.phpt")
@@ -257,8 +253,10 @@
;; The test expects an Array, but instead get the contents(?).
"ext/gd/tests/bug43073.phpt"
;; imagettftext() returns wrong coordinates.
+ "ext/gd/tests/bug48732-mb.phpt"
"ext/gd/tests/bug48732.phpt"
;; Similarly for imageftbbox().
+ "ext/gd/tests/bug48801-mb.phpt"
"ext/gd/tests/bug48801.phpt"
;; Different expected output from imagecolorallocate().
"ext/gd/tests/bug53504.phpt"
@@ -291,10 +289,11 @@
("curl" ,curl)
("cyrus-sasl" ,cyrus-sasl)
("freetype" ,freetype)
- ("gd" ,gd-for-php)
+ ("gd" ,gd)
("gdbm" ,gdbm)
("glibc" ,glibc)
("gmp" ,gmp)
+ ("gnutls" ,gnutls)
("libgcrypt" ,libgcrypt)
("libjpeg" ,libjpeg)
("libpng" ,libpng)