summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-06-29 22:51:23 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-06-29 22:51:23 +0200
commitf1728d43460e63b106dd446e70001d8e100eaf6d (patch)
tree9d211fabf9e200743be49e25d108d58ed88d2f60 /gnu/packages/perl.scm
parentcda7f4bc8ecf331d623c7d37b01931a46830c648 (diff)
parent373cc3b74a6ad33fddf75c2d773a97b1775bda8e (diff)
downloadgnu-guix-f1728d43460e63b106dd446e70001d8e100eaf6d.tar
gnu-guix-f1728d43460e63b106dd446e70001d8e100eaf6d.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm89
1 files changed, 87 insertions, 2 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index cfc73c5b3c..27b49e6652 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -20,6 +20,7 @@
;;; Copyright © 2017 Christopher Allan Webber <cwebber@dustycloud.org>
;;; Copyright © 2018 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2018 Pierre Neidhardt <ambrevar@gmail.com>
+;;; Copyright © 2018 Kei Kebreau <kkebreau@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -71,6 +72,7 @@
(patches (search-patches
"perl-file-path-CVE-2017-6512.patch"
"perl-no-sys-dirs.patch"
+ "perl-archive-tar-CVE-2018-12015.patch"
"perl-autosplit-default-time.patch"
"perl-deterministic-ordering.patch"
"perl-reproducible-build-date.patch"))))
@@ -1487,6 +1489,27 @@ provides a means of converting those data streams back into into binary
data.")
(license perl-license)))
+(define-public perl-cpan-changes
+ (package
+ (name "perl-cpan-changes")
+ (version "0.400002")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/H/HA/HAARG/CPAN-Changes-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "13dy78amkhwg278sv5im0ylyskhxpfivyl2aissqqih71nlxxvh1"))))
+ (build-system perl-build-system)
+ (home-page "http://search.cpan.org/dist/CPAN-Changes/")
+ (synopsis "Read and write @file{Changes} files")
+ (description
+ "@code{CPAN::Changes} helps users programmatically read and write
+@file{Changes} files that conform to a common specification.")
+ (license perl-license)))
+
(define-public perl-cpan-meta-check
(package
(name "perl-cpan-meta-check")
@@ -5178,6 +5201,36 @@ strictly correct manner with ExtUtils::MakeMaker, and will run on any Perl
installation version 5.005 or newer.")
(license (package-license perl))))
+(define-public perl-module-manifest
+ (package
+ (name "perl-module-manifest")
+ (version "1.09")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/E/ET/ETHER/Module-Manifest-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "16skpm804a19gsgxzn1wba3lmvc7cx5q8ly4srpyd82yy47zi5d3"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-test-exception" ,perl-test-exception)
+ ("perl-test-warn" ,perl-test-warn)))
+ (propagated-inputs
+ `(("perl-params-util" ,perl-params-util)))
+ (home-page "http://search.cpan.org/dist/Module-Manifest/")
+ (synopsis "Parse and examine a Perl distribution @file{MANIFEST} file")
+ (description
+ "@code{Module::Manifest} is a simple utility module created originally for
+use in @code{Module::Inspector}.
+
+It can load a @file{MANIFEST} file that comes in a Perl distribution tarball,
+examine the contents, and perform some simple tasks. It can also load the
+@file{MANIFEST.SKIP} file and check that.")
+ (license perl-license)))
+
(define-public perl-module-pluggable
(package
(name "perl-module-pluggable")
@@ -8426,14 +8479,14 @@ as exceptions to standard program flow.")
(define-public perltidy
(package
(name "perltidy")
- (version "20160302")
+ (version "20180220")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/perltidy/" version
"/Perl-Tidy-" version ".tar.gz"))
(sha256
(base32
- "19yw63yh5s3pq7k3nkw6nsamg5b8vvwyhgbizslgxg0mqgc4xl3d"))))
+ "0w1k5ffcrpx0fm9jgprrwy0290k6cmy7dyk83s61063migi3r5z9"))))
(build-system perl-build-system)
(home-page "http://perltidy.sourceforge.net/")
(synopsis "Perl script tidier")
@@ -9441,6 +9494,38 @@ File::Find replacement in Perl.")
interface to File::Find::Object.")
(license (package-license perl))))
+(define-public perl-file-finder
+ (package
+ (name "perl-file-finder")
+ (version "0.53")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/M/ME/MERLYN/File-Finder-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0x3a2xgzrka73lcmmwalq2mmpzxa7s6pm01ahxf677ksqsdc3jrf"))))
+ (build-system perl-build-system)
+ (propagated-inputs
+ `(("perl-text-glob" ,perl-text-glob)))
+ (home-page "http://search.cpan.org/dist/File-Finder/")
+ (synopsis "Wrapper for @code{File::Find} ala @code{find(1)}")
+ (description
+ "@code{File::Find} is great, but constructing the wanted routine can
+sometimes be a pain. @code{File::Finder} provides a wanted-writer, using
+syntax that is directly mappable to the @code{find(1)} command's syntax.
+
+A @code{File::Finder} object contains a hash of @code{File::Find} options, and
+a series of steps that mimic find's predicates. Initially, a
+@code{File::Finder} object has no steps. Each step method clones the previous
+object's options and steps, and then adds the new step, returning the new
+object. In this manner, an object can be grown, step by step, by chaining
+method calls. Furthermore, a partial sequence can be created and held, and
+used as the head of many different sequences.")
+ (license perl-license)))
+
(define-public perl-font-ttf
(package
(name "perl-font-ttf")