summaryrefslogtreecommitdiff
path: root/gnu/packages/perl.scm
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2017-08-28 20:56:30 +0100
committerChristopher Baines <mail@cbaines.net>2017-09-12 22:59:37 +0100
commit24c1c51334ccee4a6485eb2ab2dc49a2d2ffd02f (patch)
tree6e3cded4f4d01701e84a526994f6702130746e78 /gnu/packages/perl.scm
parenta6fe9304525ed0e5763821bf0fa8ec7726abeeaa (diff)
downloadgnu-guix-24c1c51334ccee4a6485eb2ab2dc49a2d2ffd02f.tar
gnu-guix-24c1c51334ccee4a6485eb2ab2dc49a2d2ffd02f.tar.gz
gnu: Add perl-net-idn-encode.
* gnu/packages/perl.scm (perl-net-idn-encode): New variable.
Diffstat (limited to 'gnu/packages/perl.scm')
-rw-r--r--gnu/packages/perl.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index d25b788e7e..aeebd23c21 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -5501,6 +5501,38 @@ cycle. Functions called in the package itself will still be bound by their
name, but they won't show up as methods on your class or instances.")
(license (package-license perl))))
+(define-public perl-net-idn-encode
+ (package
+ (name "perl-net-idn-encode")
+ (version "2.400")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/C/CF/CFAERBER/Net-IDN-Encode-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0a9knav5f9kjldrkxx1k47ivd3p23zkmi8aqgyhnxidhgasz1dlq"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-module-build" ,perl-module-build)
+ ("perl-test-nowarnings" ,perl-test-nowarnings)))
+ (home-page
+ "http://search.cpan.org/dist/Net-IDN-Encode")
+ (synopsis
+ "Internationalizing Domain Names in Applications (IDNA)")
+ (description
+ "Internationalized Domain Names (IDNs) use characters drawn from a large
+repertoire (Unicode), but IDNA allows the non-ASCII characters to be
+represented using only the ASCII characters already allowed in so-called host
+names today (letter-digit-hyphen, /[A-Z0-9-]/i).
+
+Use this module if you just want to convert domain names (or email addresses),
+using whatever IDNA standard is the best choice at the moment.")
+ (license perl-license)))
+
(define-public perl-net-statsd
(package
(name "perl-net-statsd")