summaryrefslogtreecommitdiff
path: root/gnu/packages/perl-check.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <ambrevar@gmail.com>2018-04-10 21:01:44 +0530
committerLudovic Courtès <ludo@gnu.org>2018-04-19 11:48:45 +0200
commit9a3fb60ca30246456b2f9a4d9406ef416dfb55f9 (patch)
treeed63296644ed6c0907109832c568fb8d0dd5a9d8 /gnu/packages/perl-check.scm
parente118a013c8949c592df187b84216fda8cbab9d4f (diff)
downloadgnu-guix-9a3fb60ca30246456b2f9a4d9406ef416dfb55f9.tar
gnu-guix-9a3fb60ca30246456b2f9a4d9406ef416dfb55f9.tar.gz
gnu: Add perl-test-runvalgrind
* gnu/packages/perl-check.scm (perl-test-runvalgrind): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/perl-check.scm')
-rw-r--r--gnu/packages/perl-check.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/perl-check.scm b/gnu/packages/perl-check.scm
index 1fd725f654..832efc2b78 100644
--- a/gnu/packages/perl-check.scm
+++ b/gnu/packages/perl-check.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2017 Petter <petter@mykolab.ch>
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Oleg Pykhalov <go.wigust@gmail.com>
+;;; Copyright © 2018 Pierre Neidhardt <ambrevar@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -31,6 +32,7 @@
(define-module (gnu packages perl-check)
#:use-module (guix licenses)
#:use-module (gnu packages)
+ #:use-module (gnu packages valgrind)
#:use-module (guix packages)
#:use-module (guix download)
#:use-module (guix build-system perl)
@@ -1001,6 +1003,33 @@ reported, and the tests skipped.")
(description "Test::Roo provides composable, reusable tests with roles.")
(license asl2.0)))
+(define-public perl-test-runvalgrind
+ (package
+ (name "perl-test-runvalgrind")
+ (version "0.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/S/SH/SHLOMIF/Test-RunValgrind-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0cfndkn2k9pcx290wcblwmrwh1ybs0grxjlsrp8fbqqbmmjpb53h"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-module-build" ,perl-module-build)))
+ (propagated-inputs
+ `(("perl-path-tiny" ,perl-path-tiny)
+ ("perl-test-trap" ,perl-test-trap)
+ ("valgrind" ,valgrind)))
+ (home-page "http://search.cpan.org/dist/Test-RunValgrind/")
+ (synopsis "Tests that an external program is valgrind-clean")
+ (description "Test::RunValgind checks weather Valgrind does not detect
+errors (such as memory leaks) in an arbitrary binary executable.")
+ (license x11)))
+
(define-public perl-test-script
(package
(name "perl-test-script")