summaryrefslogtreecommitdiff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-07-02 11:20:26 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-07-13 00:51:06 +0200
commite9a9298b9e43866f2d2421ab6699794ead040853 (patch)
tree9768c065eee7b2ca6b5cede0925a7d5dcf435fc7 /gnu/packages/pdf.scm
parent9761aca95cf01d225a673573f981ef324ef82479 (diff)
downloadgnu-guix-e9a9298b9e43866f2d2421ab6699794ead040853.tar
gnu-guix-e9a9298b9e43866f2d2421ab6699794ead040853.tar.gz
gnu: qpdf: Update to 8.1.0.
* gnu/packages/pdf.scm (qpdf): Update to 8.1.0. [inputs]: Move ZLIB ... [propagated-inputs]: ... here. Add LIBJPEG-TURBO. Remove PCRE. [license]: Add ASL2.0.
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 66fbb20038..de680f4990 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -678,14 +678,14 @@ line tools for batch rendering @command{pdfdraw}, rewriting files
(define-public qpdf
(package
(name "qpdf")
- (version "6.0.0")
+ (version "8.1.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://sourceforge/qpdf/qpdf/" version
"/qpdf-" version ".tar.gz"))
(sha256
(base32
- "0csj2p2gkxrc0rk8ykymlsdgfas96vzf1dip3y1x7z1q9plwgzd9"))
+ "1m3hcgip6bzjx4gd7wq1328p8zi3pq5savzncdyln6l0lcklh7vx"))
(modules '((guix build utils)))
(snippet
;; Replace shebang with the bi-lingual shell/Perl trick to remove
@@ -717,9 +717,9 @@ eval '(exit $?0)' && eval 'exec perl -wS \"$0\" ${1+\"$@\"}'
`(("pkg-config" ,pkg-config)
("perl" ,perl)))
(propagated-inputs
- `(("pcre" ,pcre)))
- (inputs
- `(("zlib" ,zlib)))
+ ;; In Requires.private of libqpdf.pc.
+ `(("libjpeg-turbo" ,libjpeg-turbo)
+ ("zlib" ,zlib)))
(synopsis "Command-line tools and library for transforming PDF files")
(description
"QPDF is a command-line program that does structural, content-preserving
@@ -727,7 +727,9 @@ transformations on PDF files. It could have been called something like
pdf-to-pdf. It includes support for merging and splitting PDFs and to
manipulate the list of pages in a PDF file. It is not a PDF viewer or a
program capable of converting PDF into other formats.")
- (license license:clarified-artistic)
+ ;; Prior to the 7.0 release, QPDF was licensed under Artistic 2.0.
+ ;; Users can still choose to use the old license at their option.
+ (license (list license:asl2.0 license:clarified-artistic))
(home-page "http://qpdf.sourceforge.net/")))
(define-public xournal