summaryrefslogtreecommitdiff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-04-14 11:52:11 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-04-15 18:51:00 +0200
commite5da4d8b4027a8300ee80a970e8628266609c126 (patch)
treef1989838170c2c226eacb59679ef9810775df3da /gnu/packages/pdf.scm
parentf46eb986c2d4d2bf35d03544e260ac8573a4158b (diff)
downloadgnu-guix-e5da4d8b4027a8300ee80a970e8628266609c126.tar
gnu-guix-e5da4d8b4027a8300ee80a970e8628266609c126.tar.gz
gnu: mupdf: Update to 1.11.
Also delete two stray patches that were added in 92ae98e2a0c2ffc807111dbf7616df47a9d3b31c and lost in a subsequent merge (mupdf/fixed was already gone at e90e0fad1b3ba79d81f02424e143ee6f4f736e8b). * gnu/packages/patches/mupdf-CVE-2017-5896.patch, gnu/packages/patches/mupdf-CVE-2017-5991.patch, gnu/packages/patches/mupdf-mujs-CVE-2016-10132.patch, gnu/packages/patches/mupdf-mujs-CVE-2016-10133.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Remove them. * gnu/packages/patches/mupdf-build-with-openjpeg-2.1.patch: Adjust. * gnu/packages/pdf.scm (mupdf): Update to 1.11. [source]: Remove mujs patches. Adjust snippet to source rename.
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index 0882d3b942..5ccaa38eea 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -531,7 +531,7 @@ extracting content or merging files.")
(define-public mupdf
(package
(name "mupdf")
- (version "1.10a")
+ (version "1.11")
(source
(origin
(method url-fetch)
@@ -539,10 +539,8 @@ extracting content or merging files.")
name "-" version "-source.tar.gz"))
(sha256
(base32
- "0dm8wcs8i29aibzkqkrn8kcnk4q0kd1v66pg48h5c3qqp4v1zk5a"))
- (patches (search-patches "mupdf-build-with-openjpeg-2.1.patch"
- "mupdf-mujs-CVE-2016-10132.patch"
- "mupdf-mujs-CVE-2016-10133.patch"))
+ "02phamcchgsmvjnb3ir7r5sssvx9fcrscn297z73b82n1jl79510"))
+ (patches (search-patches "mupdf-build-with-openjpeg-2.1.patch"))
(modules '((guix build utils)))
(snippet
;; Delete all the bundled libraries except for mujs, which is
@@ -554,7 +552,7 @@ extracting content or merging files.")
"thirdparty/glfw"
"thirdparty/harfbuzz"
"thirdparty/jbig2dec"
- "thirdparty/jpeg"
+ "thirdparty/libjpeg"
"thirdparty/openjpeg"
"thirdparty/zlib")))))
(build-system gnu-build-system)