summaryrefslogtreecommitdiff
path: root/gnu/packages/pdf.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-11-12 18:42:34 +0200
committerEfraim Flashner <efraim@flashner.co.il>2017-11-12 19:39:21 +0200
commit1650cf9284b2ae18c2e29be9d75fed93c250780e (patch)
tree7c0687b2f1036a50372ee2dca01778ad1affd593 /gnu/packages/pdf.scm
parent89ba894eb37cacbe8c38863ec63e2826f85610aa (diff)
downloadgnu-guix-1650cf9284b2ae18c2e29be9d75fed93c250780e.tar
gnu-guix-1650cf9284b2ae18c2e29be9d75fed93c250780e.tar.gz
gnu: mupdf: Unbundle mujs.
* gnu/packages/pdf.scm (mupdf)[source]: Remove bundled mujs. [inputs]: Add mujs.
Diffstat (limited to 'gnu/packages/pdf.scm')
-rw-r--r--gnu/packages/pdf.scm16
1 files changed, 3 insertions, 13 deletions
diff --git a/gnu/packages/pdf.scm b/gnu/packages/pdf.scm
index a528b7af13..84b9261885 100644
--- a/gnu/packages/pdf.scm
+++ b/gnu/packages/pdf.scm
@@ -58,6 +58,7 @@
#:use-module (gnu packages gtk)
#:use-module (gnu packages image)
#:use-module (gnu packages imagemagick)
+ #:use-module (gnu packages javascript)
#:use-module (gnu packages lesstif)
#:use-module (gnu packages linux)
#:use-module (gnu packages lua)
@@ -581,19 +582,7 @@ extracting content or merging files.")
"mupdf-CVE-2017-14687.patch"
"mupdf-CVE-2017-15587.patch"))
(modules '((guix build utils)))
- (snippet
- ;; Delete all the bundled libraries except for mujs, which is
- ;; developed by the same team as mupdf and has no releases.
- ;; TODO Package mujs and don't use the bundled copy.
- '(for-each delete-file-recursively
- '("thirdparty/curl"
- "thirdparty/freetype"
- "thirdparty/glfw"
- "thirdparty/harfbuzz"
- "thirdparty/jbig2dec"
- "thirdparty/libjpeg"
- "thirdparty/openjpeg"
- "thirdparty/zlib")))))
+ (snippet '(delete-file-recursively "thirdparty"))))
(build-system gnu-build-system)
(inputs
`(("curl" ,curl)
@@ -603,6 +592,7 @@ extracting content or merging files.")
("libjpeg" ,libjpeg)
("libx11" ,libx11)
("libxext" ,libxext)
+ ("mujs" ,mujs)
("openjpeg" ,openjpeg)
("openssl" ,openssl)
("zlib" ,zlib)))