summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-03-30 22:59:53 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-03-30 22:59:53 +0200
commit84157bb8bf2c610584e0836047da4c710f8eaf76 (patch)
treebe5d8c7238e32802221db55a3ee83e7f6a58affb /gnu/packages/patches
parentfa63939acba69e11df44073a7eb687bd2ba48349 (diff)
parent03d0aa8b22223b67ec9bbd363c4d5800efdbaf82 (diff)
downloadgnu-guix-84157bb8bf2c610584e0836047da4c710f8eaf76.tar
gnu-guix-84157bb8bf2c610584e0836047da4c710f8eaf76.tar.gz
Merge branch 'master' into core-updates
Most conflicts are from 6fd52309b8f52c9bb59fccffac53e029ce94b698.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/ceph-disable-cpu-optimizations.patch46
-rw-r--r--gnu/packages/patches/ceph-skip-collect-sys-info-test.patch29
-rw-r--r--gnu/packages/patches/ceph-skip-unittest_blockdev.patch28
-rw-r--r--gnu/packages/patches/lxsession-use-gapplication.patch152
-rw-r--r--gnu/packages/patches/thefuck-test-environ.patch14
5 files changed, 269 insertions, 0 deletions
diff --git a/gnu/packages/patches/ceph-disable-cpu-optimizations.patch b/gnu/packages/patches/ceph-disable-cpu-optimizations.patch
new file mode 100644
index 0000000000..6d20fe3da4
--- /dev/null
+++ b/gnu/packages/patches/ceph-disable-cpu-optimizations.patch
@@ -0,0 +1,46 @@
+Disable CPU optimizations not supported by the vast majority of
+x86_64 systems. Also don't add anything for i686.
+
+--- a/cmake/modules/SIMDExt.cmake 2017-03-23 22:22:58.254071694 +0100
++++ b/cmake/modules/SIMDExt.cmake 2017-03-23 22:23:22.446848845 +0100
+@@ -6,10 +6,6 @@
+ # HAVE_INTEL_SSE
+ # HAVE_INTEL_SSE2
+ # HAVE_INTEL_SSE3
+-# HAVE_INTEL_SSSE3
+-# HAVE_INTEL_PCLMUL
+-# HAVE_INTEL_SSE4_1
+-# HAVE_INTEL_SSE4_2
+ #
+ # SIMD_COMPILE_FLAGS
+ #
+@@ -56,7 +53,7 @@
+ if(HAVE_ARM_NEON)
+ set(SIMD_COMPILE_FLAGS "${SIMD_COMPILE_FLAGS} -mfpu=neon")
+ endif()
+-elseif(CMAKE_SYSTEM_PROCESSOR MATCHES "i386|i686|amd64|x86_64|AMD64")
++elseif(CMAKE_SYSTEM_PROCESSOR MATCHES "amd64|x86_64|AMD64")
+ set(HAVE_INTEL 1)
+ CHECK_C_COMPILER_FLAG(-msse HAVE_INTEL_SSE)
+ if(HAVE_INTEL_SSE)
+@@ -70,20 +67,4 @@
+ if(HAVE_INTEL_SSE3)
+ set(SIMD_COMPILE_FLAGS "${SIMD_COMPILE_FLAGS} -msse3")
+ endif()
+- CHECK_C_COMPILER_FLAG(-mssse3 HAVE_INTEL_SSSE3)
+- if(HAVE_INTEL_SSSE3)
+- set(SIMD_COMPILE_FLAGS "${SIMD_COMPILE_FLAGS} -mssse3")
+- endif()
+- CHECK_C_COMPILER_FLAG(-mpclmul HAVE_INTEL_PCLMUL)
+- if(HAVE_INTEL_PCLMUL)
+- set(SIMD_COMPILE_FLAGS "${SIMD_COMPILE_FLAGS} -mpclmul")
+- endif()
+- CHECK_C_COMPILER_FLAG(-msse4.1 HAVE_INTEL_SSE4_1)
+- if(HAVE_INTEL_SSE4_1)
+- set(SIMD_COMPILE_FLAGS "${SIMD_COMPILE_FLAGS} -msse4.1")
+- endif()
+- CHECK_C_COMPILER_FLAG(-msse4.2 HAVE_INTEL_SSE4_2)
+- if(HAVE_INTEL_SSE4_2)
+- set(SIMD_COMPILE_FLAGS "${SIMD_COMPILE_FLAGS} -msse4.2")
+- endif()
+ endif()
diff --git a/gnu/packages/patches/ceph-skip-collect-sys-info-test.patch b/gnu/packages/patches/ceph-skip-collect-sys-info-test.patch
new file mode 100644
index 0000000000..f210799254
--- /dev/null
+++ b/gnu/packages/patches/ceph-skip-collect-sys-info-test.patch
@@ -0,0 +1,29 @@
+This test fails because /etc/os-release is not available.
+
+diff --git a/src/test/common/test_util.cc b/src/test/common/test_util.cc
+index 288dd37db1..95b6cd4b30 100644
+--- a/src/test/common/test_util.cc
++++ b/src/test/common/test_util.cc
+@@ -31,19 +31,3 @@ TEST(util, unit_to_bytesize)
+
+ ASSERT_EQ(65536ll, unit_to_bytesize(" 64K", &cerr));
+ }
+-
+-#if defined(__linux__)
+-TEST(util, collect_sys_info)
+-{
+- map<string, string> sys_info;
+-
+- CephContext *cct = (new CephContext(CEPH_ENTITY_TYPE_CLIENT))->get();
+- collect_sys_info(&sys_info, cct);
+-
+- ASSERT_TRUE(sys_info.find("distro") != sys_info.end());
+- ASSERT_TRUE(sys_info.find("distro_version") != sys_info.end());
+- ASSERT_TRUE(sys_info.find("distro_description") != sys_info.end());
+-
+- cct->put();
+-}
+-#endif
+--
+2.11.1
+
diff --git a/gnu/packages/patches/ceph-skip-unittest_blockdev.patch b/gnu/packages/patches/ceph-skip-unittest_blockdev.patch
new file mode 100644
index 0000000000..43b9984862
--- /dev/null
+++ b/gnu/packages/patches/ceph-skip-unittest_blockdev.patch
@@ -0,0 +1,28 @@
+This test tries to walk a sysfs path and hits a null pointer exception.
+
+/tmp/guix-build-ceph-12.0.0.drv-0/ceph-12.0.0/src/test/common/test_blkdev.cc:32: Failure
+Expected: (dir) != (nullptr), actual: NULL vs 8-byte object <00-00 00-00 00-00 00-00>
+
+diff --git a/src/test/common/CMakeLists.txt b/src/test/common/CMakeLists.txt
+index 5172663898..ac84085eaa 100644
+--- a/src/test/common/CMakeLists.txt
++++ b/src/test/common/CMakeLists.txt
+@@ -12,15 +12,6 @@ target_link_libraries(get_command_descriptions
+ ${CMAKE_DL_LIBS}
+ )
+
+-if(HAVE_BLKID)
+-# unittest_blkdev
+-add_executable(unittest_blkdev
+- test_blkdev.cc
+- )
+-add_ceph_unittest(unittest_blkdev ${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/unittest_blkdev)
+-target_link_libraries(unittest_blkdev global ${BLKID_LIBRARIES})
+-endif(HAVE_BLKID)
+-
+ # unittest_bloom_filter
+ add_executable(unittest_bloom_filter
+ test_bloom_filter.cc
+--
+2.11.1
+
diff --git a/gnu/packages/patches/lxsession-use-gapplication.patch b/gnu/packages/patches/lxsession-use-gapplication.patch
new file mode 100644
index 0000000000..3f2269a42f
--- /dev/null
+++ b/gnu/packages/patches/lxsession-use-gapplication.patch
@@ -0,0 +1,152 @@
+Upstream patch to remove libunique dependency, and use glib >= 2.28.0
+to handle unique apps both for GTK+ 2 and 3.
+https://sourceforge.net/p/lxde/patches/539/
+
+
+From a7d3b40a79a7a16c1f5d50d2bd466570258dae29 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Ball=C3=B3=20Gy=C3=B6rgy?= <ballogyor@gmail.com>
+Date: Sun, 22 Jan 2017 01:09:59 +0100
+Subject: [PATCH] Use GApplication for unique app handling
+
+Remove libunique dependency, and use glib >= 2.28.0 to handle unique apps both for GTK+ 2 and 3.
+---
+ Makefile.am | 6 ------
+ configure.ac | 7 +------
+ lxclipboard/main.vala | 16 +---------------
+ lxpolkit/main.vala | 16 +---------------
+ 4 files changed, 3 insertions(+), 42 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index c2e1fe8..e3a3b97 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -90,9 +90,6 @@ if USE_GTK3
+ lxclipboard_lxclipboard_VALAFLAGS += --define USE_GTK3
+ else
+ lxclipboard_lxclipboard_VALAFLAGS += --define USE_GTK2
+-lxclipboard_lxclipboard_VALAFLAGS += --pkg unique-1.0
+-lxclipboard_lxclipboard_CPPFLAGS += $(UNIQUE_CFLAGS)
+-lxclipboard_lxclipboard_LDADD += $(UNIQUE_LIBS)
+ endif
+
+ lxpolkit_lxpolkit_vala_SOURCES = \
+@@ -137,9 +134,6 @@ if USE_GTK3
+ lxpolkit_lxpolkit_VALAFLAGS += --define USE_GTK3
+ else
+ lxpolkit_lxpolkit_VALAFLAGS += --define USE_GTK2
+-lxpolkit_lxpolkit_VALAFLAGS += --pkg unique-1.0
+-lxpolkit_lxpolkit_CPPFLAGS += $(UNIQUE_CFLAGS)
+-lxpolkit_lxpolkit_LDADD += $(UNIQUE_LIBS)
+ endif
+
+ lxsession_db_lxsession_db_SOURCES = \
+diff --git a/configure.ac b/configure.ac
+index 06ddbb3..9126f4d 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -45,7 +45,7 @@ PKG_CHECK_MODULES(X11, [x11])
+ AC_SUBST(X11_CFLAGS)
+ AC_SUBST(X11_LIBS)
+
+-PKG_CHECK_MODULES(GLIB, [glib-2.0 >= 2.6.0])
++PKG_CHECK_MODULES(GLIB, [glib-2.0 >= 2.28.0])
+ AC_SUBST(GLIB_CFLAGS)
+ AC_SUBST(GLIB_LIBS)
+
+@@ -79,11 +79,6 @@ else
+ CFLAGS="$CFLAGS -D USE_GTK2"
+ gtk_modules="gtk+-2.0 >= 2.6.0"
+ VALA_GTK_LIBS="gtk+-2.0"
+-
+- PKG_CHECK_MODULES(UNIQUE, [unique-1.0])
+- AC_SUBST(UNIQUE_CFLAGS)
+- AC_SUBST(UNIQUE_LIBS)
+-
+ fi
+ PKG_CHECK_MODULES(GTK, [$gtk_modules])
+ AC_SUBST(GTK_CFLAGS)
+diff --git a/lxclipboard/main.vala b/lxclipboard/main.vala
+index bee4044..3d4a8d7 100644
+--- a/lxclipboard/main.vala
++++ b/lxclipboard/main.vala
+@@ -17,9 +17,6 @@
+ * MA 02110-1301, USA.
+ */
+ using Gtk;
+-#if USE_GTK2
+-using Unique;
+-#endif
+
+ namespace Lxsession
+ {
+@@ -28,17 +25,7 @@ namespace Lxsession
+ public static int main(string[] args)
+ {
+ Gtk.init (ref args);
+-#if USE_GTK2
+- Unique.App app = new Unique.App("org.lxde.lxclipboard", null);
+-
+- if(app.is_running)
+- {
+- message("lxclipboard is already running. Existing");
+- return 0;
+- }
+-#endif
+-# if USE_GTK3
+- Gtk.Application app = new Gtk.Application (
++ GLib.Application app = new GLib.Application (
+ "org.lxde.lxclipboard",
+ GLib.ApplicationFlags.FLAGS_NONE);
+ app.register ();
+@@ -48,7 +35,6 @@ namespace Lxsession
+ message("lxclipboard is already running. Existing");
+ return 0;
+ }
+-#endif
+
+ clipboard_start ();
+
+diff --git a/lxpolkit/main.vala b/lxpolkit/main.vala
+index c0d6ae2..50c3cb7 100644
+--- a/lxpolkit/main.vala
++++ b/lxpolkit/main.vala
+@@ -17,9 +17,6 @@
+ * MA 02110-1301, USA.
+ */
+ using Gtk;
+-#if USE_GTK2
+-using Unique;
+-#endif
+
+ const string GETTEXT_PACKAGE = "lxsession";
+
+@@ -33,17 +30,7 @@ namespace Lxsession
+ Intl.bind_textdomain_codeset(GETTEXT_PACKAGE, "utf-8");
+
+ Gtk.init (ref args);
+-#if USE_GTK2
+- Unique.App app = new Unique.App("org.lxde.lxpolkit", null);
+-
+- if(app.is_running)
+- {
+- message(_("lxpolkit is already running. Existing"));
+- return 0;
+- }
+-#endif
+-# if USE_GTK3
+- Gtk.Application app = new Gtk.Application (
++ GLib.Application app = new GLib.Application (
+ "org.lxde.lxpolkit",
+ GLib.ApplicationFlags.FLAGS_NONE);
+ app.register ();
+@@ -53,7 +40,6 @@ namespace Lxsession
+ message(_("lxpolkit is already running. Existing"));
+ return 0;
+ }
+-#endif
+
+ policykit_agent_init();
+
+--
+2.11.0
+
diff --git a/gnu/packages/patches/thefuck-test-environ.patch b/gnu/packages/patches/thefuck-test-environ.patch
new file mode 100644
index 0000000000..0c602a38c4
--- /dev/null
+++ b/gnu/packages/patches/thefuck-test-environ.patch
@@ -0,0 +1,14 @@
+Retain environment setting of "HOME" for tests that need os.path.expanduser()
+to return a readable directory in the build chroot.
+
+--- thefuck-3.15/tests/test_conf.py
++++ thefuck-3.15/tests/test_conf.py
+@@ -12,7 +12,7 @@
+
+ @pytest.fixture
+ def environ(monkeypatch):
+- data = {}
++ data = {"HOME": os.environ.get("HOME")}
+ monkeypatch.setattr('thefuck.conf.os.environ', data)
+ return data
+