summaryrefslogtreecommitdiff
path: root/gnu/packages/patches
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-10-17 20:53:24 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-10-17 20:53:24 +0200
commit16f14f63db7a370d3917cf9c7d7e3735b0f59855 (patch)
tree367b77f69504cdb55109dcb68aa5a7bc3fe9693b /gnu/packages/patches
parentd02bb02f7d833ad371c53c346b6cb77f01377cf4 (diff)
downloadgnu-guix-16f14f63db7a370d3917cf9c7d7e3735b0f59855.tar
gnu-guix-16f14f63db7a370d3917cf9c7d7e3735b0f59855.tar.gz
gnu: Python: Adjust grafts for core-updates merge.
This adjust the grafts from a55ebe2e3a7b438b4eec06c594440d3a0fb06a25 and 90aeaee861845142843a0f988fa4ff016c723cdb to apply to Python 2.7.15 and 3.7.0. * gnu/packages/patches/python2-CVE-2018-1060.patch, gnu/packages/patches/python2-CVE-2018-1061.patch: Delete files. * gnu/local.mk (dist_patch_DATA): Remove them. * gnu/packages/python.scm (python-2/fixed): Remove patches that are already present in 2.7.15. (python-3/fixed): Remove obsolete phase.
Diffstat (limited to 'gnu/packages/patches')
-rw-r--r--gnu/packages/patches/python2-CVE-2018-1060.patch20
-rw-r--r--gnu/packages/patches/python2-CVE-2018-1061.patch20
2 files changed, 0 insertions, 40 deletions
diff --git a/gnu/packages/patches/python2-CVE-2018-1060.patch b/gnu/packages/patches/python2-CVE-2018-1060.patch
deleted file mode 100644
index 5eb7ccfbc9..0000000000
--- a/gnu/packages/patches/python2-CVE-2018-1060.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-Fix CVE-2018-1060:
-https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-1060
-
-Taken from upstream commit (sans test and NEWS):
-https://github.com/python/cpython/commit/e052d40cea15f582b50947f7d906b39744dc62a2
-
-diff --git a/Lib/poplib.py b/Lib/poplib.py
-index b91e5f72d2ca..a238510b38fc 100644
---- a/Lib/poplib.py
-+++ b/Lib/poplib.py
-@@ -274,7 +274,7 @@ def rpop(self, user):
- return self._shortcmd('RPOP %s' % user)
-
-
-- timestamp = re.compile(r'\+OK.*(<[^>]+>)')
-+ timestamp = re.compile(br'\+OK.[^<]*(<.*>)')
-
- def apop(self, user, secret):
- """Authorisation
-
diff --git a/gnu/packages/patches/python2-CVE-2018-1061.patch b/gnu/packages/patches/python2-CVE-2018-1061.patch
deleted file mode 100644
index 6caab24b4d..0000000000
--- a/gnu/packages/patches/python2-CVE-2018-1061.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-Fix CVE-2018-1061:
-
-https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2018-1061
-
-Taken from upstream commit (sans test and NEWS):
-https://github.com/python/cpython/commit/e052d40cea15f582b50947f7d906b39744dc62a2
-
-diff --git a/Lib/difflib.py b/Lib/difflib.py
-index 1c6fbdbedcb7..788a92df3f89 100644
---- a/Lib/difflib.py
-+++ b/Lib/difflib.py
-@@ -1103,7 +1103,7 @@ def _qformat(self, aline, bline, atags, btags):
-
- import re
-
--def IS_LINE_JUNK(line, pat=re.compile(r"\s*#?\s*$").match):
-+def IS_LINE_JUNK(line, pat=re.compile(r"\s*(?:#\s*)?$").match):
- r"""
- Return 1 for ignorable line: iff `line` is blank or contains a single '#'.
-