summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/gspell-dash-test.patch
diff options
context:
space:
mode:
authorKei Kebreau <kei@openmailbox.org>2017-06-15 21:52:57 -0400
committerKei Kebreau <kei@openmailbox.org>2017-06-15 21:58:37 -0400
commitf54efbdc46be99e7bf0f2d31a766cfb2b5dab996 (patch)
treea3203112e863c7027359ddea37f0890775cb49cc /gnu/packages/patches/gspell-dash-test.patch
parenta147fadd3b60a0489bcf4b4cdce8254c51c16e3f (diff)
downloadgnu-guix-f54efbdc46be99e7bf0f2d31a766cfb2b5dab996.tar
gnu-guix-f54efbdc46be99e7bf0f2d31a766cfb2b5dab996.tar.gz
gnu: gspell: Update to 1.4.1.
* gnu/packages/gnome.scm (gspell): Update to 1.4.1. * gnu/packages/patches/gspell-dash-test.patch: Adjust accordingly.
Diffstat (limited to 'gnu/packages/patches/gspell-dash-test.patch')
-rw-r--r--gnu/packages/patches/gspell-dash-test.patch20
1 files changed, 13 insertions, 7 deletions
diff --git a/gnu/packages/patches/gspell-dash-test.patch b/gnu/packages/patches/gspell-dash-test.patch
index e737921c4b..1c9d77cfba 100644
--- a/gnu/packages/patches/gspell-dash-test.patch
+++ b/gnu/packages/patches/gspell-dash-test.patch
@@ -1,16 +1,22 @@
Somehow, Aspell 0.60.6.1 and aspell-dict-en-2016.11.20-0 don't consider
this a valid spelling. Skip it.
---- gspell-1.3.2/testsuite/test-checker.c 2017-05-17 16:02:40.832415940 +0200
-+++ gspell-1.3.2/testsuite/test-checker.c 2017-05-17 16:02:50.768351895 +0200
-@@ -101,9 +101,6 @@ test_dashes (void)
-
- checker = gspell_checker_new (lang);
-
+TODO: Migrate to using hunspell. According to upstream, this bug won't be fixed.
+See https://bugzilla.gnome.org/show_bug.cgi?id=772406.
+--- a/testsuite/test-checker.c 2017-03-24 09:50:50.000000000 -0400
++++ b/testsuite/test-checker.c 2017-06-15 21:47:07.116173895 -0400
+@@ -105,10 +105,11 @@
+ * be considered deprecated, it is better to use hunspell, so WONTFIX.
+ * For more details, see:
+ * https://bugzilla.gnome.org/show_bug.cgi?id=772406
++ *
++ * correctly_spelled = gspell_checker_check_word (checker, "spell-checking", -1, &error);
++ * g_assert_no_error (error);
++ * g_assert (correctly_spelled);
+ */
- correctly_spelled = gspell_checker_check_word (checker, "spell-checking", -1, &error);
- g_assert_no_error (error);
- g_assert (correctly_spelled);
correctly_spelled = gspell_checker_check_word (checker, "nrst-auie", -1, &error);
g_assert_no_error (error);
-