summaryrefslogtreecommitdiff
path: root/gnu/packages/patches/gnucash-price-quotes-perl.patch
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-07-09 19:19:09 -0500
committerEric Bavier <bavier@member.fsf.org>2015-09-10 03:21:55 -0500
commit8b94dffde89a87a31c50d5c73ffb6f8a1b97616a (patch)
tree0c2c78276495c7e8a3f6a135b9c1463c13cfc80b /gnu/packages/patches/gnucash-price-quotes-perl.patch
parenta6d0b306c20f236324e4bd661d0f82750ee00e90 (diff)
downloadgnu-guix-8b94dffde89a87a31c50d5c73ffb6f8a1b97616a.tar
gnu-guix-8b94dffde89a87a31c50d5c73ffb6f8a1b97616a.tar.gz
gnu: gnucash: Add Finance::Quote support.
* gnu/packages/patches/gnucash-price-quotes-perl.patch: New patch. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/gnucash.scm (gnucash)[source]: Use it. [inputs]: Add perl-date-manip and perl-finance-quote. [arguments]: Add 'wrap-programs' phase. Move below inputs.
Diffstat (limited to 'gnu/packages/patches/gnucash-price-quotes-perl.patch')
-rw-r--r--gnu/packages/patches/gnucash-price-quotes-perl.patch23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/patches/gnucash-price-quotes-perl.patch b/gnu/packages/patches/gnucash-price-quotes-perl.patch
new file mode 100644
index 0000000000..982763f0ec
--- /dev/null
+++ b/gnu/packages/patches/gnucash-price-quotes-perl.patch
@@ -0,0 +1,23 @@
+After wrapping gnc-fq-check and gnc-fq-helper we can no longer execute them
+with perl, so execute them directly instead.
+
+--- gnucash-2.6.6/src/scm/price-quotes.scm.orig 2014-04-27 17:42:28.000000000 -0500
++++ gnucash-2.6.6/src/scm/price-quotes.scm 2015-07-09 16:12:11.196218472 -0500
+@@ -74,7 +74,7 @@
+ (define (start-program)
+ (if (not (string-null? gnc:*finance-quote-check*))
+ (set! program (gnc-spawn-process-async
+- (list "perl" "-w" gnc:*finance-quote-check*) #t))))
++ (list gnc:*finance-quote-check*) #t))))
+
+ (define (get-sources)
+ (if (not (null? program))
+@@ -158,7 +158,7 @@
+ (define (start-quoter)
+ (if (not (string-null? gnc:*finance-quote-helper*))
+ (set! quoter (gnc-spawn-process-async
+- (list "perl" "-w" gnc:*finance-quote-helper*) #t))))
++ (list gnc:*finance-quote-helper*) #t))))
+
+ (define (get-quotes)
+ (if (not (null? quoter))