aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/patches/emacs-undohist-ignored.patch
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-04-08 00:54:01 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-04-08 00:54:01 +0200
commitba00235a9652bb129ff6867ffc3c7cfafe1cca09 (patch)
tree1ce56f512707e89362e1fed3d5b26d690462fbda /gnu/packages/patches/emacs-undohist-ignored.patch
parentf19ccdc62ca721b68745c35b046826b356f46c62 (diff)
parent0e2b0b05accdea7c3f016f8483d0ec04021114d3 (diff)
downloadgnu-guix-ba00235a9652bb129ff6867ffc3c7cfafe1cca09.tar
gnu-guix-ba00235a9652bb129ff6867ffc3c7cfafe1cca09.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/patches/emacs-undohist-ignored.patch')
-rw-r--r--gnu/packages/patches/emacs-undohist-ignored.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/patches/emacs-undohist-ignored.patch b/gnu/packages/patches/emacs-undohist-ignored.patch
new file mode 100644
index 0000000000..c1ad827a26
--- /dev/null
+++ b/gnu/packages/patches/emacs-undohist-ignored.patch
@@ -0,0 +1,27 @@
+From 52bfd419bf9022726048f818d955b8ea10a16d5c Mon Sep 17 00:00:00 2001
+From: Patrick Mosby <info@schreiblogade.de>
+Date: Mon, 7 Sep 2015 09:05:56 +0200
+Subject: [PATCH] Don't save undo file for ignored files.
+
+This fixes #4.
+---
+ undohist.el | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/undohist.el b/undohist.el
+index b184a26..de60356 100644
+--- a/undohist.el
++++ b/undohist.el
+@@ -164,7 +164,8 @@ To use undohist, you just call this function."
+ undohist-ignored-files)))
+
+ (defun undohist-save-1 ()
+- (when (consp buffer-undo-list)
++ (when (and (consp buffer-undo-list)
++ (undohist-recover-file-p (buffer-file-name (current-buffer))))
+ (let ((file (make-undohist-file-name (buffer-file-name)))
+ (contents `((digest . ,(md5 (current-buffer)))
+ (undo-list . ,(undohist-encode buffer-undo-list)))))
+--
+2.21.0
+