summaryrefslogtreecommitdiff
path: root/gnu/packages/password-utils.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-08-01 18:02:40 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-08-06 19:13:06 +0300
commit99672f7b1d255b5cdac73870dfc272ca6799485b (patch)
treed18b0d5bac48c2ffb3f66bf59a7e62ebcb2a57e4 /gnu/packages/password-utils.scm
parent3ea2eaa8f35059ae64004d224992ee53a135cc80 (diff)
downloadgnu-guix-99672f7b1d255b5cdac73870dfc272ca6799485b.tar
gnu-guix-99672f7b1d255b5cdac73870dfc272ca6799485b.tar.gz
gnu: Add keepassxc.
* gnu/packages/password-utils.scm (keepassxc): New variable.
Diffstat (limited to 'gnu/packages/password-utils.scm')
-rw-r--r--gnu/packages/password-utils.scm35
1 files changed, 34 insertions, 1 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 08591d1086..cdd705956d 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Steve Sprang <scs@stevesprang.com>
-;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015, 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2015 Aljosha Papsch <misc@rpapsch.de>
;;; Copyright © 2016 Christopher Allan Webber <cwebber@dustycloud.org>
;;; Copyright © 2016 Jessica Tallon <tsyesika@tsyesika.se>
@@ -75,6 +75,39 @@
human.")
(license license:gpl2)))
+(define-public keepassxc
+ (package
+ (name "keepassxc")
+ (version "2.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/keepassxreboot/" name
+ "/releases/download/" version "/keepassxc-"
+ version "-src.tar.xz"))
+ (sha256
+ (base32
+ "0nby6aq6w8g7c9slzahf7i34sbj8majf8rhmqqww87v6kaypxi3i"))))
+ (build-system cmake-build-system)
+ (inputs
+ `(("libgcrypt" ,libgcrypt)
+ ("libxi" ,libxi)
+ ("libxtst" ,libxtst)
+ ("qtbase" ,qtbase)
+ ("qtx11extras" ,qtx11extras)
+ ("zlib" ,zlib)))
+ (native-inputs
+ `(("qttools" ,qttools)))
+ (home-page "https://www.keepassxc.org")
+ (synopsis "Password manager")
+ (description "KeePassXC is a password manager or safe which helps you to
+manage your passwords in a secure way. You can put all your passwords in one
+database, which is locked with one master key or a key-file which can be stored
+on an external storage device. The databases are encrypted using the
+algorithms AES or Twofish.")
+ ;; Non functional parts use various licences.
+ (license license:gpl3)))
+
(define-public keepassx
(package
(name "keepassx")