summaryrefslogtreecommitdiff
path: root/gnu/packages/openstack.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2015-11-23 20:27:37 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-01-17 22:37:04 +0200
commit8f0cc2ffce9ebf013a6fd3696e096517123ee935 (patch)
tree37251d0442220106ac50e28e9e3460bd9144b638 /gnu/packages/openstack.scm
parent7a5b944eb5bc9df149cca4eb018e58e106084fbb (diff)
downloadgnu-guix-8f0cc2ffce9ebf013a6fd3696e096517123ee935.tar
gnu-guix-8f0cc2ffce9ebf013a6fd3696e096517123ee935.tar.gz
gnu: Add python-swiftclient.
* gnu/packages/openstack.scm (python-swiftclient, python2-swiftclient): New variables.
Diffstat (limited to 'gnu/packages/openstack.scm')
-rw-r--r--gnu/packages/openstack.scm54
1 files changed, 54 insertions, 0 deletions
diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
index a4be670965..392ff88291 100644
--- a/gnu/packages/openstack.scm
+++ b/gnu/packages/openstack.scm
@@ -750,3 +750,57 @@ LDAP.")
,@(alist-delete
"python-oauthlib"
(package-native-inputs keystoneclient)))))))
+
+(define-public python-swiftclient
+ (package
+ (name "python-swiftclient")
+ (version "2.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "python-swiftclient" version))
+ (sha256
+ (base32
+ "1j33l4z9vqh0scfncl4fxg01zr1hgqxhhai6gvcih1gccqm4nd7p"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-pbr", python-pbr)
+ ("python-setuptools" ,python-setuptools)
+ ("python-sphinx" ,python-sphinx)
+ ;; The folloing packages are needed for the tests.
+ ("python-coverage" ,python-coverage)
+ ("python-discover" ,python-discover)
+ ("python-hacking" ,python-hacking)
+ ("python-mock" ,python-mock)
+ ("python-oslosphinx" ,python-oslosphinx)
+ ("python-keystoneclient" ,python-keystoneclient)
+ ("python-testrepository" ,python-testrepository)
+ ("python-testtools" ,python-testtools)))
+ (propagated-inputs
+ `(("python-requests" ,python-requests)
+ ("python-six" ,python-six)))
+ (home-page "http://www.openstack.org/")
+ (synopsis "OpenStack Object Storage API Client Library")
+ (description
+ "OpenStack Object Storage (code-named Swift) creates redundant, scalable
+object storage using clusters of standardized servers to store petabytes of
+accessible data. It is not a file system or real-time data storage system, but
+rather a long-term storage system for a more permanent type of static data that
+can be retrieved, leveraged, and then updated if necessary. Primary examples of
+data that best fit this type of storage model are virtual machine images, photo
+storage, email storage and backup archiving. Having no central \"brain\" or
+master point of control provides greater scalability, redundancy and
+permanence.")
+ (license asl2.0)))
+
+(define-public python2-swiftclient
+ (let ((swiftclient (package-with-python2 python-swiftclient)))
+ (package (inherit swiftclient)
+ (propagated-inputs
+ `(("python2-futures" ,python2-futures)
+ ,@(package-propagated-inputs swiftclient)))
+ (native-inputs
+ `(("python2-keystoneclient" ,python2-keystoneclient)
+ ,@(alist-delete
+ "python-keystoneclient"
+ (package-native-inputs swiftclient)))))))