summaryrefslogtreecommitdiff
path: root/gnu/packages/ocaml.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-11-19 23:28:18 +0100
committerJulien Lepiller <julien@lepiller.eu>2018-12-18 22:16:52 +0100
commit48b27902ded3aa89e18b8e46bb0a48f91ea4ae23 (patch)
treecd7f22ba7a6e7cb6b15ba3719d618be89ff02cb9 /gnu/packages/ocaml.scm
parent5d0712638f3131ec34a1632eee3a9a9fed610cc5 (diff)
downloadgnu-guix-48b27902ded3aa89e18b8e46bb0a48f91ea4ae23.tar
gnu-guix-48b27902ded3aa89e18b8e46bb0a48f91ea4ae23.tar.gz
gnu: ocaml-cppo: Use dune-build-system.
* gnu/packages/ocaml.scm (ocaml-cppo): Use dune-build-system.
Diffstat (limited to 'gnu/packages/ocaml.scm')
-rw-r--r--gnu/packages/ocaml.scm20
1 files changed, 4 insertions, 16 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 5d941a1123..fe5c6b55c8 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -3023,24 +3023,12 @@ provide a tool that can be used to:
(sha256 (base32
"1dkm3d5h6h56y937gcdk2wixlpzl59vv5pmiafglr89p20kf7gqf"))
(file-name (string-append name "-" version ".tar.gz"))))
- (build-system ocaml-build-system)
+ (build-system dune-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (replace 'build
- (lambda _
- (invoke "dune" "build" "@install" "--profile" "release")
- #t))
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (invoke "dune" "install"
- "--prefix" (assoc-ref outputs "out"))
- #t)))
- #:tests? #f))
+ `(#:tests? #f
+ #:build-flags (list "--profile" "release")))
(native-inputs
- `(("dune" ,dune)
- ("ocamlbuild" ,ocamlbuild)))
+ `(("ocamlbuild" ,ocamlbuild)))
(home-page "https://github.com/mjambon/cppo")
(synopsis "Equivalent of the C preprocessor for OCaml programs")
(description "Cppo is an equivalent of the C preprocessor for OCaml