summaryrefslogtreecommitdiff
path: root/gnu/packages/nettle.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-04-09 18:42:08 +0200
committerLudovic Courtès <ludo@gnu.org>2015-04-09 18:49:30 +0200
commit2891974c35c5a24395b9583db3dfec4170734650 (patch)
tree0548e992ebb0639500b30e8e0b1385137a98f955 /gnu/packages/nettle.scm
parent0be199c976332fd655c547bb122d1214cc9bc452 (diff)
downloadgnu-guix-2891974c35c5a24395b9583db3dfec4170734650.tar
gnu-guix-2891974c35c5a24395b9583db3dfec4170734650.tar.gz
gnu: nettle: Update to 3.1.
* gnu/packages/nettle.scm (nettle): Update to 3.1. Add 'arguments' field.
Diffstat (limited to 'gnu/packages/nettle.scm')
-rw-r--r--gnu/packages/nettle.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/nettle.scm b/gnu/packages/nettle.scm
index ae432c7bc7..827fed2b1d 100644
--- a/gnu/packages/nettle.scm
+++ b/gnu/packages/nettle.scm
@@ -17,6 +17,7 @@
;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
(define-module (gnu packages nettle)
+ #:use-module (guix utils)
#:use-module (guix licenses)
#:use-module (guix packages)
#:use-module (guix download)
@@ -57,11 +58,17 @@ themselves.")
;; This version is not API-compatible with version 2. In particular GnuTLS
;; cannot use it yet. So keep it separate.
(package (inherit nettle-2)
- (version "3.0")
+ (version "3.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/nettle/nettle-"
version ".tar.gz"))
(sha256
(base32
- "04yrpjz33vrj6j0zxc153b00f93i8hs41syr1ryp7sr64fyw0lcn"))))))
+ "1ly9kz5fgc8ilykz07crqwgjsfn4p2s6565gj1aq0w4fr179v1gn"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments nettle-2)
+ ((#:configure-flags flags)
+ ;; Build "fat" binaries where the right implementation is chosen at
+ ;; run time based on CPU features (starting from 3.1.)
+ `(cons "--enable-fat" ,flags))))))