summaryrefslogtreecommitdiff
path: root/gnu/packages/ncurses.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2017-12-18 10:04:57 +0100
committerLudovic Courtès <ludo@gnu.org>2017-12-18 10:06:32 +0100
commit11b9a22366a8a0bd8f9ccdb95873085899c175ed (patch)
tree0cf6ed12950c0c28fb01843806c3471a449dc712 /gnu/packages/ncurses.scm
parent01564e5ab5b9c11fea81a87ac7f8d2fcdb81668d (diff)
downloadgnu-guix-11b9a22366a8a0bd8f9ccdb95873085899c175ed.tar
gnu-guix-11b9a22366a8a0bd8f9ccdb95873085899c175ed.tar.gz
gnu: ncurses: Fix cross-compilation.
This fixes a regression introduced in 667082d59104d4b964dce878f5e8c0f8ad1be958 whereby cross-compiling ncurses would fail. * gnu/packages/ncurses.scm (ncurses)[arguments]: In CONFIGURE-PHASE, get "rollup-patch" from NATIVE-INPUTS when cross-compiling.
Diffstat (limited to 'gnu/packages/ncurses.scm')
-rw-r--r--gnu/packages/ncurses.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/ncurses.scm b/gnu/packages/ncurses.scm
index 524252da75..dcf7bee8b3 100644
--- a/gnu/packages/ncurses.scm
+++ b/gnu/packages/ncurses.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015, 2017 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014, 2016 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015, 2017 Leo Famulari <leo@famulari.name>
;;; Copyright © 2016 ng0 <ng0@we.make.ritual.n0.is>
@@ -73,8 +73,8 @@
configure-flags)
configure-flags))))))
(apply-rollup-patch-phase
- '(lambda* (#:key inputs #:allow-other-keys)
- (copy-file (assoc-ref inputs "rollup-patch")
+ '(lambda* (#:key inputs native-inputs #:allow-other-keys)
+ (copy-file (assoc-ref (or native-inputs inputs) "rollup-patch")
(string-append (getcwd) "/rollup-patch.sh.bz2"))
(and (zero? (system* "bzip2" "-d" "rollup-patch.sh.bz2"))
(zero? (system* "sh" "rollup-patch.sh")))))