summaryrefslogtreecommitdiff
path: root/gnu/packages/multiprecision.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2013-10-09 16:14:23 +0200
committerLudovic Courtès <ludo@gnu.org>2013-10-09 16:14:23 +0200
commita22dc0c49aed0babe16ef92ae24847b343b7eb02 (patch)
tree2d1ce88952d68274437dc07fbffbea688bc0eea3 /gnu/packages/multiprecision.scm
parent668d48a6847bcdc69d2c6e6aa44090f566ecd05b (diff)
downloadgnu-guix-a22dc0c49aed0babe16ef92ae24847b343b7eb02.tar
gnu-guix-a22dc0c49aed0babe16ef92ae24847b343b7eb02.tar.gz
Synchronize package descriptions with the Womb.
* gnu/packages/algebra.scm, gnu/packages/aspell.scm, gnu/packages/autotools.scm, gnu/packages/base.scm, gnu/packages/bash.scm, gnu/packages/bison.scm, gnu/packages/cdrom.scm, gnu/packages/cflow.scm, gnu/packages/compression.scm, gnu/packages/cpio.scm, gnu/packages/cppi.scm, gnu/packages/ddrescue.scm, gnu/packages/dejagnu.scm, gnu/packages/ed.scm, gnu/packages/emacs.scm, gnu/packages/fdisk.scm, gnu/packages/freeipmi.scm, gnu/packages/gawk.scm, gnu/packages/gcal.scm, gnu/packages/gcc.scm, gnu/packages/gdb.scm, gnu/packages/gdbm.scm, gnu/packages/gettext.scm, gnu/packages/ghostscript.scm, gnu/packages/global.scm, gnu/packages/gnunet.scm, gnu/packages/gnupg.scm, gnu/packages/gnutls.scm, gnu/packages/gperf.scm, gnu/packages/gprolog.scm, gnu/packages/groff.scm, gnu/packages/grub.scm, gnu/packages/gsasl.scm, gnu/packages/guile.scm, gnu/packages/gv.scm, gnu/packages/help2man.scm, gnu/packages/idutils.scm, gnu/packages/indent.scm, gnu/packages/less.scm, gnu/packages/libidn.scm, gnu/packages/libsigsegv.scm, gnu/packages/libunistring.scm, gnu/packages/lightning.scm, gnu/packages/linux.scm, gnu/packages/lsh.scm, gnu/packages/m4.scm, gnu/packages/mail.scm, gnu/packages/maths.scm, gnu/packages/multiprecision.scm, gnu/packages/nano.scm, gnu/packages/ncurses.scm, gnu/packages/nettle.scm, gnu/packages/ocrad.scm, gnu/packages/oggvorbis.scm, gnu/packages/parted.scm, gnu/packages/plotutils.scm, gnu/packages/pth.scm, gnu/packages/readline.scm, gnu/packages/recutils.scm, gnu/packages/rush.scm, gnu/packages/scheme.scm, gnu/packages/screen.scm, gnu/packages/shishi.scm, gnu/packages/smalltalk.scm, gnu/packages/system.scm, gnu/packages/texinfo.scm, gnu/packages/time.scm, gnu/packages/unrtf.scm, gnu/packages/version-control.scm, gnu/packages/wdiff.scm, gnu/packages/wget.scm, gnu/packages/which.scm, gnu/packages/xnee.scm, gnu/packages/zile.scm: Change value of the 'description' field to that of the Womb.
Diffstat (limited to 'gnu/packages/multiprecision.scm')
-rw-r--r--gnu/packages/multiprecision.scm43
1 files changed, 9 insertions, 34 deletions
diff --git a/gnu/packages/multiprecision.scm b/gnu/packages/multiprecision.scm
index 16383d1ec1..6692d26b59 100644
--- a/gnu/packages/multiprecision.scm
+++ b/gnu/packages/multiprecision.scm
@@ -46,25 +46,11 @@
"--enable-cxx")))
(synopsis "Multiple-precision arithmetic library")
(description
- "GMP is a free library for arbitrary precision arithmetic, operating on
-signed integers, rational numbers, and floating point numbers. There is no
-practical limit to the precision except the ones implied by the available
-memory in the machine GMP runs on. GMP has a rich set of functions, and the
-functions have a regular interface.
-
-The main target applications for GMP are cryptography applications and
-research, Internet security applications, algebra systems, computational
-algebra research, etc.
-
-GMP is carefully designed to be as fast as possible, both for small operands
-and for huge operands. The speed is achieved by using fullwords as the basic
-arithmetic type, by using fast algorithms, with highly optimised assembly
-code for the most common inner loops for a lot of CPUs, and by a general
-emphasis on speed.
-
-GMP is faster than any other bignum library. The advantage for GMP increases
-with the operand sizes for many operations, since GMP uses asymptotically
-faster algorithms.")
+ "GMP is a library for arbitrary precision arithmetic, operating on
+signed integers, rational numbers and floating point numbers. The precision
+is only limited by the available memory. The library is highly optimized,
+with a design focus on execution speed. It is aimed at use in, for example,
+cryptography and computational algebra.")
(license lgpl3+)
(home-page "http://gmplib.org/")))
@@ -83,14 +69,8 @@ faster algorithms.")
(propagated-inputs `(("gmp" ,gmp))) ; <mpfr.h> refers to <gmp.h>
(synopsis "C library for arbitrary precision floating-point arithmetic")
(description
- "The GNU MPFR library is a C library for multiple-precision
-floating-point computations with correct rounding. MPFR is based on the GMP
-multiple-precision library.
-
-The main goal of MPFR is to provide a library for multiple-precision
-floating-point computation which is both efficient and has a well-defined
-semantics. It copies the good ideas from the ANSI/IEEE-754 standard for
-double-precision floating-point arithmetic (53-bit mantissa).")
+ "MPFR is a C library for performing multiple-precision, floating-point
+computations with correct rounding.")
(license lgpl3+)
(home-page "http://www.mpfr.org/")))
@@ -110,12 +90,7 @@ double-precision floating-point arithmetic (53-bit mantissa).")
("mpfr" ,mpfr)))
(synopsis "C library for arbitrary precision complex arithmetic")
(description
- "GNU MPC is a C library for the arithmetic of complex numbers with
-arbitrarily high precision and correct rounding of the result. It extends
-the principles of the IEEE-754 standard for fixed precision real floating
-point numbers to complex numbers, providing well-defined semantics for
-every operation. At the same time, speed of operation at high precision
-is a major design goal. The library is built upon and follows the same
-principles as GNU MPFR.")
+ "GNU MPC is a C library for performing arithmetic on complex numbers.
+It supports arbitrarily high precision and it correctly rounds the results.")
(license lgpl3+)
(home-page "http://mpc.multiprecision.org/")))