summaryrefslogtreecommitdiff
path: root/gnu/packages/multiprecision.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2016-04-10 13:53:42 +0200
committerMathieu Lirzin <mthl@gnu.org>2016-04-13 19:52:33 +0200
commit61bb355532f2612ee99d0d9438dbea5ad4ec1f4d (patch)
treede76a93a5660d4af282b580be0e8931200d4874d /gnu/packages/multiprecision.scm
parent89cbec89a57c2e10042a19c298c8c000e6bce13b (diff)
downloadgnu-guix-61bb355532f2612ee99d0d9438dbea5ad4ec1f4d.tar
gnu-guix-61bb355532f2612ee99d0d9438dbea5ad4ec1f4d.tar.gz
gnu: Add mpfi.
* gnu/packages/multiprecision.scm (mpfi): New variable. Signed-off-by: Mathieu Lirzin <mthl@gnu.org>
Diffstat (limited to 'gnu/packages/multiprecision.scm')
-rw-r--r--gnu/packages/multiprecision.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/multiprecision.scm b/gnu/packages/multiprecision.scm
index ad507706db..d97bf9ba28 100644
--- a/gnu/packages/multiprecision.scm
+++ b/gnu/packages/multiprecision.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2012, 2013, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2016 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -119,3 +120,28 @@ floating-point computations with correct rounding.")
It supports arbitrarily high precision and it correctly rounds the results.")
(license lgpl3+)
(home-page "http://mpc.multiprecision.org/")))
+
+(define-public mpfi
+ (package
+ (name "mpfi")
+ (version "1.5.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://gforge.inria.fr/frs/download.php/"
+ "file/30130/mpfi-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1g2q6i7dqx40p4gw11da6jgfcbzmm26wxc69fwv8zpcdyg32a9za"))))
+ (build-system gnu-build-system)
+ (propagated-inputs `(("gmp" ,gmp) ; <mpfi.h> refers to both
+ ("mpfr" ,mpfr)))
+ (synopsis "C library for arbitrary precision interval arithmetic")
+ (description "MPFI is intended to be a portable library written in C for
+arbitrary precision interval arithmetic with intervals represented using MPFR
+reliable floating-point numbers. It is based on the GNU MP library and on the
+MPFR library. The purpose of an arbitrary precision interval arithmetic is on
+the one hand to get guaranteed results, thanks to interval computation, and on
+the other hand to obtain accurate results, thanks to multiple precision
+arithmetic.")
+ (license lgpl2.1+)
+ (home-page "https://perso.ens-lyon.fr/nathalie.revol/software.html")))