summaryrefslogtreecommitdiff
path: root/gnu/packages/messaging.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-05-06 15:56:24 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-05-06 15:56:24 +0200
commit12bd588346f8b2fb3709acfe0ee89d153da2db34 (patch)
tree459d8eb13a0508170ba462fe61a8b45fb55ea79f /gnu/packages/messaging.scm
parent7d5adf013127c89826e9fbe9f1a67265b3538609 (diff)
parent8e020519b45bbdb9403164bd4403f2465bac99ad (diff)
downloadgnu-guix-12bd588346f8b2fb3709acfe0ee89d153da2db34.tar
gnu-guix-12bd588346f8b2fb3709acfe0ee89d153da2db34.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/messaging.scm')
-rw-r--r--gnu/packages/messaging.scm40
1 files changed, 28 insertions, 12 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index 3a1a0176ef..c74977eea8 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -440,32 +440,48 @@ compromised.")
(define-public znc
(package
(name "znc")
- (version "1.6.6")
+ (version "1.7.0")
(source (origin
(method url-fetch)
(uri (string-append "http://znc.in/releases/archive/znc-"
version ".tar.gz"))
(sha256
(base32
- "09cmsnxvi7jg9a0dicf60fxnxdff4aprw7h8vjqlj5ywf6y43f3z"))))
+ "0vxra50418bsjfdpf8vl70fijv8syvasjqdxfyjliff6k91k2zn0"))))
+ ;; TODO: autotools support has been deprecated, and new features like i18n
+ ;; are only supported when building with cmake.
(build-system gnu-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
(add-after 'unpack 'unpack-googletest
(lambda* (#:key inputs #:allow-other-keys)
- (zero? (system* "tar" "xf"
- (assoc-ref inputs "googletest-source"))))))
+ (mkdir-p "googletest")
+ (copy-recursively (assoc-ref inputs "googletest-source")
+ "googletest")
+ #t)))
#:configure-flags '("--enable-python"
"--enable-perl"
"--enable-cyrus"
- ,(string-append "--with-gtest="
- "googletest-release-"
- (package-version googletest)
- "/googletest"))
+ "--with-gmock=googletest/googlemock"
+ "--with-gtest=googletest/googletest")
#:test-target "test"))
(native-inputs
- `(("googletest-source" ,(package-source googletest))
+ `(("googletest-source"
+ ;; ZNC 1.7 needs a newer, unreleased googletest (a release is planned
+ ;; <https://github.com/google/googletest/issues/1583>, so don't update
+ ;; the public GOOGLETEST to an unstable version). The commit is taken
+ ;; from ‘third_party/googletest’ in the ZNC git repository.
+ ,(let ((commit "9737e63c69e94ac5777caa0bc77c77d5206467f3"))
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/google/googletest")
+ (commit commit)))
+ (file-name (git-file-name "googletest-for-znc" commit))
+ (sha256
+ (base32
+ "0ya36n8d62zbxk6p22yffgx43mqhx2fz41gqqwbpdshjryf3wvxj")))))
("pkg-config" ,pkg-config)
("perl" ,perl)
("python" ,python)))
@@ -476,9 +492,9 @@ compromised.")
("cyrus-sasl" ,cyrus-sasl)))
(home-page "https://znc.in")
(synopsis "IRC network bouncer")
- (description "ZNC is an IRC network bouncer or BNC. It can detach the
-client from the actual IRC server, and also from selected channels. Multiple
-clients from different locations can connect to a single ZNC account
+ (description "ZNC is an @dfn{IRC network bouncer} or @dfn{BNC}. It can
+detach the client from the actual IRC server, and also from selected channels.
+Multiple clients from different locations can connect to a single ZNC account
simultaneously and therefore appear under the same nickname on IRC.")
(license license:asl2.0)))