summaryrefslogtreecommitdiff
path: root/gnu/packages/maths.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-11-07 11:52:08 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-11-07 12:26:33 +0100
commitbb47aca5e75b32874d7b7b16902bcd085e54547e (patch)
tree9ceb3056d6f4b79bbaae4226a32a7a4fccca9dc7 /gnu/packages/maths.scm
parentd639d8884c85584e2487ed08fd8b1faca826e982 (diff)
downloadgnu-guix-bb47aca5e75b32874d7b7b16902bcd085e54547e.tar
gnu-guix-bb47aca5e75b32874d7b7b16902bcd085e54547e.tar.gz
gnu: Add hdf5-1.10.
* gnu/packages/maths.scm (hdf5-1.10): New variable.
Diffstat (limited to 'gnu/packages/maths.scm')
-rw-r--r--gnu/packages/maths.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index d14e61f26f..808ab5345b 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -884,6 +884,25 @@ extremely large and complex data collections.")
(license (license:x11-style
"http://www.hdfgroup.org/ftp/HDF5/current/src/unpacked/COPYING"))))
+(define-public hdf5-1.10
+ (package (inherit hdf5)
+ (version "1.10.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (list (string-append "https://support.hdfgroup.org/ftp/HDF5/releases/"
+ "hdf5-" (version-major+minor version)
+ "/hdf5-" version "/src/hdf5-"
+ version ".tar.bz2")
+ (string-append "https://support.hdfgroup.org/ftp/HDF5/"
+ "current"
+ (apply string-append
+ (take (string-split version #\.) 2))
+ "/src/hdf5-" version ".tar.bz2")))
+ (sha256
+ (base32 "1pr85fa1sh2ky6ai2hs3f21lp252grl2cq3wbyi4rh7dm83gyrqj"))
+ (patches (list (search-patch "hdf5-config-date.patch")))))))
+
(define-public hdf-java
(package
(name "hdf-java")