summaryrefslogtreecommitdiff
path: root/gnu/packages/mate.scm
diff options
context:
space:
mode:
authorng0 <ng0@infotropique.org>2017-12-30 22:51:49 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2017-12-30 22:55:25 +0100
commit95073bfc3eaf5b36b36758ea28e468c51774a06c (patch)
tree1e6ec8181f98918ec728e8251a4ef0fe127479d7 /gnu/packages/mate.scm
parent1da3338c3e1456223b81745b9695f2cb09a0f045 (diff)
downloadgnu-guix-95073bfc3eaf5b36b36758ea28e468c51774a06c.tar
gnu-guix-95073bfc3eaf5b36b36758ea28e468c51774a06c.tar.gz
gnu: Add mate-polkit.
* gnu/packages/mate.scm (mate-polkit): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/mate.scm')
-rw-r--r--gnu/packages/mate.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/mate.scm b/gnu/packages/mate.scm
index c6c2aa1c01..ab112c6c69 100644
--- a/gnu/packages/mate.scm
+++ b/gnu/packages/mate.scm
@@ -1484,6 +1484,40 @@ can be used as backgrounds in the MATE Desktop environment.")
MATE Desktop to monitor your system resources and usage.")
(license license:gpl2)))
+(define-public mate-polkit
+ (package
+ (name "mate-polkit")
+ (version "1.18.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://pub.mate-desktop.org/releases/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "15vf2hnyjg8zsw3iiwjwi497yygkmvpnn6w1hik7dfw4a621w0gc"))))
+ (build-system glib-or-gtk-build-system)
+ (native-inputs
+ `(("gettext" ,gettext-minimal)
+ ("gtk-doc" ,gtk-doc)
+ ("intltool" ,intltool)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("accountsservice" ,accountsservice)
+ ("glib" ,glib)
+ ("gobject-introspection" ,gobject-introspection)
+ ("gtk+" ,gtk+)
+ ("gdk-pixbuf" ,gdk-pixbuf)
+ ("polkit" ,polkit)))
+ (home-page "https://mate-desktop.org/")
+ (synopsis "DBus specific service for MATE")
+ (description
+ "MATE Polkit is a MATE specific DBUS service that is
+used to bring up authentication dialogs.")
+ (license license:lgpl2.1)))
+
(define-public mate
(package
(name "mate")