summaryrefslogtreecommitdiff
path: root/gnu/packages/mate.scm
diff options
context:
space:
mode:
authorng0 <ng0@infotropique.org>2017-12-30 22:45:37 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2017-12-30 22:55:24 +0100
commit538b752b0eff478e57bfce5b370275258261d0f7 (patch)
tree80dad3a347ba2d91d71d9a0402cdede705a32f2c /gnu/packages/mate.scm
parentbf7f29491db377bed6f088463f54edbdb9e68d61 (diff)
downloadgnu-guix-538b752b0eff478e57bfce5b370275258261d0f7.tar
gnu-guix-538b752b0eff478e57bfce5b370275258261d0f7.tar.gz
gnu: Add mate-common.
* gnu/packages/mate.scm (mate-common): New variable. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
Diffstat (limited to 'gnu/packages/mate.scm')
-rw-r--r--gnu/packages/mate.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/mate.scm b/gnu/packages/mate.scm
index 1b1da05797..e276575c92 100644
--- a/gnu/packages/mate.scm
+++ b/gnu/packages/mate.scm
@@ -63,6 +63,27 @@
#:use-module (gnu packages xml)
#:use-module (gnu packages xorg))
+(define-public mate-common
+ (package
+ (name "mate-common")
+ (version "1.18.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://pub.mate-desktop.org/releases/"
+ (version-major+minor version) "/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1005laf3z1h8qczm7pmwr40r842665cv6ykhjg7r93vldra48z6p"))))
+ (build-system gnu-build-system)
+ (home-page "https://mate-desktop.org/")
+ (synopsis "Common files for development of MATE packages")
+ (description
+ "Mate Common includes common files and macros used by
+MATE applications.")
+ (license license:gpl3+)))
+
(define-public mate-icon-theme
(package
(name "mate-icon-theme")