summaryrefslogtreecommitdiff
path: root/gnu/packages/man.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-09-07 10:25:42 +0200
committerRicardo Wurmus <rekado@elephly.net>2016-09-07 20:54:01 +0200
commite79b3c37e3f3a00241e7a980b45eb0e30f942b94 (patch)
tree5f378097dbd6d759c398a59d5162dc3681fdd352 /gnu/packages/man.scm
parentd6a07ee6751cdd414d702194dbeb0fd71f0781c9 (diff)
downloadgnu-guix-e79b3c37e3f3a00241e7a980b45eb0e30f942b94.tar
gnu-guix-e79b3c37e3f3a00241e7a980b45eb0e30f942b94.tar.gz
gnu: man-db: Use modify-phases syntax.
* gnu/packages/man.scm (man-db)[arguments]: Use modify-phases syntax.
Diffstat (limited to 'gnu/packages/man.scm')
-rw-r--r--gnu/packages/man.scm25
1 files changed, 12 insertions, 13 deletions
diff --git a/gnu/packages/man.scm b/gnu/packages/man.scm
index 9ffbba9de9..a5ee2d3121 100644
--- a/gnu/packages/man.scm
+++ b/gnu/packages/man.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2012, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2014 David Thompson <dthompson2@worcester.edu>
-;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2016 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015 Alex Kost <alezost@gmail.com>
;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
;;;
@@ -69,18 +69,17 @@ a flexible and convenient way.")
(build-system gnu-build-system)
(arguments
'(#:phases
- (alist-cons-after
- 'patch-source-shebangs 'patch-test-shebangs
- (lambda* (#:key outputs #:allow-other-keys)
- ;; Patch shebangs in test scripts.
- (let ((out (assoc-ref outputs "out")))
- (for-each (lambda (file)
- (substitute* file
- (("#! /bin/sh")
- (string-append "#!" (which "sh")))))
- (remove file-is-directory?
- (find-files "src/tests" ".*")))))
- %standard-phases)
+ (modify-phases %standard-phases
+ (add-after 'patch-source-shebangs 'patch-test-shebangs
+ (lambda* (#:key outputs #:allow-other-keys)
+ ;; Patch shebangs in test scripts.
+ (let ((out (assoc-ref outputs "out")))
+ (for-each (lambda (file)
+ (substitute* file
+ (("#! /bin/sh")
+ (string-append "#!" (which "sh")))))
+ (remove file-is-directory?
+ (find-files "src/tests" ".*")))))))
#:configure-flags
(let ((groff (assoc-ref %build-inputs "groff"))
(less (assoc-ref %build-inputs "less"))