summaryrefslogtreecommitdiff
path: root/gnu/packages/lxqt.scm
diff options
context:
space:
mode:
authorMeiyo Peng <meiyo.peng@gmail.com>2018-10-18 19:48:09 +0800
committer宋文武 <iyzsong@member.fsf.org>2018-10-26 21:20:21 +0800
commit4b88ab554c5f6ea71910265e9cd96129af138f1f (patch)
treef19a8037a2d351c654540168c5f7aac645d363d9 /gnu/packages/lxqt.scm
parent604bdae7e502923ecb1b78700912767beaec48d2 (diff)
downloadgnu-guix-4b88ab554c5f6ea71910265e9cd96129af138f1f.tar
gnu-guix-4b88ab554c5f6ea71910265e9cd96129af138f1f.tar.gz
gnu: Add screengrab.
* gnu/packages/lxqt.scm (screengrab): New variable. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/lxqt.scm')
-rw-r--r--gnu/packages/lxqt.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index 27d4c01e5e..a5ffd0921d 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -992,3 +992,32 @@ image viewer.")
(synopsis "The terminal widget for QTerminal")
(description "QTermWidget is a terminal emulator widget for Qt 5.")
(license license:lgpl2.1+)))
+
+(define-public screengrab
+ (package
+ (name "screengrab")
+ (version "1.99")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
+ version "/" name "-" version ".tar.xz"))
+ (sha256
+ (base32 "17y8rsx9fixvxv2byq8d6c01vry10nv07f8jy85vz7zp4f0rgzz3"))))
+ (build-system cmake-build-system)
+ (inputs
+ `(("kwindowsystem" ,kwindowsystem)
+ ("libqtxdg" ,libqtxdg)
+ ("qtbase" ,qtbase)
+ ("qtsvg" ,qtsvg)
+ ("qtx11extras" ,qtx11extras)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("qttools" ,qttools)))
+ (arguments
+ '(#:tests? #f)) ; no tests
+ (home-page "https://lxqt.org/")
+ (synopsis "Crossplatform tool for fast making screenshots")
+ (description "ScreenGrab is a program for fast creating screenshots, and
+easily publishing them on internet image hosting services.")
+ (license license:lgpl2.1+)))