summaryrefslogtreecommitdiff
path: root/gnu/packages/lxqt.scm
diff options
context:
space:
mode:
authorMeiyo Peng <meiyo.peng@gmail.com>2018-10-18 19:19:06 +0800
committer宋文武 <iyzsong@member.fsf.org>2018-10-26 21:05:12 +0800
commit26127ebb97d48d8cddc2e287f9b9a063e8599dc1 (patch)
treecbe5774527286b08ad5a07af15ca4d179f47450d /gnu/packages/lxqt.scm
parent0aab234954207bb8b285c0ebe68477cb3171508d (diff)
downloadgnu-guix-26127ebb97d48d8cddc2e287f9b9a063e8599dc1.tar
gnu-guix-26127ebb97d48d8cddc2e287f9b9a063e8599dc1.tar.gz
gnu: lxqt.scm: Sort packages into base, core, etc.
* gnu/packages/lxqt.scm: Sort packages into base, core, etc. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/lxqt.scm')
-rw-r--r--gnu/packages/lxqt.scm315
1 files changed, 165 insertions, 150 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index 8f01744cc5..4528444ca3 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -50,6 +50,9 @@
#:use-module (gnu packages xdisorg)
#:use-module (gnu packages xorg))
+
+;; Third party libraries
+
(define-public libdbusmenu-qt
(package
(name "libdbusmenu-qt")
@@ -79,82 +82,57 @@ protocol. The DBusMenu protocol makes it possible for applications to export
and import their menus over DBus.")
(license license:lgpl2.1+)))
-(define-public libfm-qt
+(define-public libstatgrab
(package
- (name "libfm-qt")
- (version "0.13.1")
+ (name "libstatgrab")
+ (version "0.91")
(source
(origin
(method url-fetch)
- (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
- version "/" name "-" version ".tar.xz"))
+ (uri (string-append "https://ftp.i-scream.org/pub/i-scream/libstatgrab/"
+ name "-" version ".tar.gz"))
(sha256
- (base32 "0p0lbz7dh5c38zq3yp1v1mm99ymg7mqr3h7yzniif2hipmgvxsv9"))))
- (build-system cmake-build-system)
+ (base32 "1azinx2yzs442ycwq6p15skl3mscmqj7fd5hq7fckhjp92735s83"))))
+ (build-system gnu-build-system)
(arguments
- '(#:tests? #f ; no tests
- #:configure-flags
- ;; TODO: prefetch translations files from 'lxqt-l10n'.
- '("-DPULL_TRANSLATIONS=NO")))
- (inputs
- `(("glib" ,glib)
- ("libexif" ,libexif)
- ("libfm" ,libfm)
- ("libxcb" ,libxcb)
- ("menu-cache" ,menu-cache)
- ("pcre" ,pcre)
- ("qtbase" ,qtbase)
- ("qtx11extras" ,qtx11extras)))
+ '(#:configure-flags '("--enable-tests")))
(native-inputs
- `(("pkg-config" ,pkg-config)
- ("lxqt-build-tools" ,lxqt-build-tools)
- ("qttools" ,qttools)))
- (home-page "https://lxqt.org/")
- (synopsis "Qt binding for libfm")
- (description "libfm-qt is the Qt port of libfm, a library providing
-components to build desktop file managers which belongs to LXDE.")
- (license license:lgpl2.1+)))
+ ;; For testing.
+ `(("perl" ,perl)))
+ (home-page "https://www.i-scream.org/libstatgrab/")
+ (synopsis "Provides access to statistics about the system")
+ (description "libstatgrab is a library that provides cross platform access
+to statistics about the system on which it's run.")
+ ;; Libraries are under LGPL2.1+, and programs under GPLv2+.
+ (license license:gpl2+)))
-(define-public liblxqt
+
+;; Base
+
+(define-public lxqt-build-tools
(package
- (name "liblxqt")
- (version "0.13.0")
+ (name "lxqt-build-tools")
+ (version "0.5.0")
(source
(origin
(method url-fetch)
- (uri (string-append
- "https://github.com/lxqt/" name "/releases/download/"
- version "/" name "-" version ".tar.xz"))
+ (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
+ version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "0fba0nq5b9fvvmklcikcd4nwhzlp5d6k1q1f80r34kncdzfvj7dl"))))
+ (base32 "13b5x26p6ycnwzlgg1cgvlc88wjrjmlb3snrrmzh0xgh9h6hhvd6"))))
(build-system cmake-build-system)
(arguments
- `(#:tests? #f ; no tests
- #:configure-flags
- ;; TODO: prefetch translations files from 'lxqt-l10n'.
- '("-DPULL_TRANSLATIONS=NO")
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-source
- (lambda _
- (substitute* "CMakeLists.txt"
- (("DESTINATION \"\\$\\{POLKITQT-1_POLICY_FILES_INSTALL_DIR\\}")
- "DESTINATION \"${CMAKE_INSTALL_PREFIX}/share/polkit-1/actions"))
- #t)))))
- (inputs
- `(("kwindowsystem" ,kwindowsystem)
- ("libqtxdg" ,libqtxdg)
- ("libxscrnsaver" ,libxscrnsaver)
- ("polkit-qt" ,polkit-qt)
- ("qtsvg" ,qtsvg)
- ("qtx11extras" ,qtx11extras)))
+ `(#:tests? #f)) ; no tests
(native-inputs
- `(("lxqt-build-tools" ,lxqt-build-tools)
- ("qttools" ,qttools)))
- (home-page "https://lxqt.org/")
- (synopsis "Core utility library for all LXQt components")
- (description "liblxqt provides the basic libraries shared by the
-components of the LXQt desktop environment.")
+ `(("pkg-config" ,pkg-config)
+ ("glib" ,glib)))
+ (inputs
+ `(("qtbase" ,qtbase)))
+ (synopsis "LXQt Build tools")
+ (description
+ "Lxqt-build-tools is providing several tools needed to build LXQt
+itself as well as other components maintained by the LXQt project.")
+ (home-page "https://lxqt.org")
(license license:lgpl2.1+)))
(define-public libqtxdg
@@ -192,29 +170,47 @@ components of the LXQt desktop environment.")
in Qt.")
(license license:lgpl2.1+)))
-(define-public libstatgrab
+(define-public liblxqt
(package
- (name "libstatgrab")
- (version "0.91")
+ (name "liblxqt")
+ (version "0.13.0")
(source
(origin
(method url-fetch)
- (uri (string-append "https://ftp.i-scream.org/pub/i-scream/libstatgrab/"
- name "-" version ".tar.gz"))
+ (uri (string-append
+ "https://github.com/lxqt/" name "/releases/download/"
+ version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "1azinx2yzs442ycwq6p15skl3mscmqj7fd5hq7fckhjp92735s83"))))
- (build-system gnu-build-system)
+ (base32 "0fba0nq5b9fvvmklcikcd4nwhzlp5d6k1q1f80r34kncdzfvj7dl"))))
+ (build-system cmake-build-system)
(arguments
- '(#:configure-flags '("--enable-tests")))
+ `(#:tests? #f ; no tests
+ #:configure-flags
+ ;; TODO: prefetch translations files from 'lxqt-l10n'.
+ '("-DPULL_TRANSLATIONS=NO")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-source
+ (lambda _
+ (substitute* "CMakeLists.txt"
+ (("DESTINATION \"\\$\\{POLKITQT-1_POLICY_FILES_INSTALL_DIR\\}")
+ "DESTINATION \"${CMAKE_INSTALL_PREFIX}/share/polkit-1/actions"))
+ #t)))))
+ (inputs
+ `(("kwindowsystem" ,kwindowsystem)
+ ("libqtxdg" ,libqtxdg)
+ ("libxscrnsaver" ,libxscrnsaver)
+ ("polkit-qt" ,polkit-qt)
+ ("qtsvg" ,qtsvg)
+ ("qtx11extras" ,qtx11extras)))
(native-inputs
- ;; For testing.
- `(("perl" ,perl)))
- (home-page "https://www.i-scream.org/libstatgrab/")
- (synopsis "Provides access to statistics about the system")
- (description "libstatgrab is a library that provides cross platform access
-to statistics about the system on which it's run.")
- ;; Libraries are under LGPL2.1+, and programs under GPLv2+.
- (license license:gpl2+)))
+ `(("lxqt-build-tools" ,lxqt-build-tools)
+ ("qttools" ,qttools)))
+ (home-page "https://lxqt.org/")
+ (synopsis "Core utility library for all LXQt components")
+ (description "liblxqt provides the basic libraries shared by the
+components of the LXQt desktop environment.")
+ (license license:lgpl2.1+)))
(define-public libsysstat
(package
@@ -239,6 +235,9 @@ to statistics about the system on which it's run.")
and memory usage or network traffic.")
(license license:lgpl2.1+)))
+
+;; Core
+
(define-public lxqt-about
(package
(name "lxqt-about")
@@ -313,32 +312,6 @@ LXQt and the system it's running on.")
the operating system LXQt is running on.")
(license license:lgpl2.1+)))
-(define-public lxqt-build-tools
- (package
- (name "lxqt-build-tools")
- (version "0.5.0")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
- version "/" name "-" version ".tar.xz"))
- (sha256
- (base32 "13b5x26p6ycnwzlgg1cgvlc88wjrjmlb3snrrmzh0xgh9h6hhvd6"))))
- (build-system cmake-build-system)
- (arguments
- `(#:tests? #f)) ; no tests
- (native-inputs
- `(("pkg-config" ,pkg-config)
- ("glib" ,glib)))
- (inputs
- `(("qtbase" ,qtbase)))
- (synopsis "LXQt Build tools")
- (description
- "Lxqt-build-tools is providing several tools needed to build LXQt
-itself as well as other components maintained by the LXQt project.")
- (home-page "https://lxqt.org")
- (license license:lgpl2.1+)))
-
(define-public lxqt-config
(package
(name "lxqt-config")
@@ -429,41 +402,6 @@ shortcuts in LXQt sessions, that is shortcuts which apply to the LXQt session
as a whole and are not limited to distinct applications.")
(license license:lgpl2.1+)))
-(define-public lxqt-themes
- (package
- (name "lxqt-themes")
- (version "0.13.0")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
- version "/" name "-" version ".tar.xz"))
- (sha256
- (base32 "13kkkzjx8bgnwckz79j273azvm4za66i4cp2qhxwdpxh0fwziklf"))))
- (build-system cmake-build-system)
- (native-inputs
- `(("lxqt-build-tools" ,lxqt-build-tools)))
- (arguments
- `(#:tests? #f ; no tests
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-source
- (lambda _
- (substitute* '("CMakeLists.txt")
- (("DESTINATION \"\\$\\{LXQT_GRAPHICS_DIR\\}")
- "DESTINATION \"${CMAKE_INSTALL_PREFIX}/share/lxqt/graphics"))
- (substitute* '("themes/CMakeLists.txt")
- (("DESTINATION \"\\$\\{LXQT_SHARE_DIR\\}")
- "DESTINATION \"${CMAKE_INSTALL_PREFIX}/share/lxqt"))
- #t)))))
- (home-page "https://lxqt.org/")
- (synopsis "Themes, graphics and icons for LXQt")
- (description "This package comprises a number of graphic files and themes
-for LXQt.")
- ;; The whole package is released under LGPL 2.1+, while the LXQt logo is
- ;; licensed under CC-BY-SA 3.0.
- (license license:lgpl2.1+)))
-
(define-public lxqt-notificationd
(package
(name "lxqt-notificationd")
@@ -846,37 +784,78 @@ respectively. As such it enables regular users to launch applications with
permissions of other users including root.")
(license license:lgpl2.1+)))
-(define-public pavucontrol-qt
+(define-public lxqt-themes
(package
- (name "pavucontrol-qt")
- (version "0.4.0")
+ (name "lxqt-themes")
+ (version "0.13.0")
(source
(origin
(method url-fetch)
(uri (string-append "https://github.com/lxqt/" name "/releases/download/"
version "/" name "-" version ".tar.xz"))
(sha256
- (base32 "0pqvhhgw7d00wqw5v3ghm4l8250zy7bqpvhff6l7y1lw0z2fvcp6"))))
+ (base32 "13kkkzjx8bgnwckz79j273azvm4za66i4cp2qhxwdpxh0fwziklf"))))
+ (build-system cmake-build-system)
+ (native-inputs
+ `(("lxqt-build-tools" ,lxqt-build-tools)))
+ (arguments
+ `(#:tests? #f ; no tests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-source
+ (lambda _
+ (substitute* '("CMakeLists.txt")
+ (("DESTINATION \"\\$\\{LXQT_GRAPHICS_DIR\\}")
+ "DESTINATION \"${CMAKE_INSTALL_PREFIX}/share/lxqt/graphics"))
+ (substitute* '("themes/CMakeLists.txt")
+ (("DESTINATION \"\\$\\{LXQT_SHARE_DIR\\}")
+ "DESTINATION \"${CMAKE_INSTALL_PREFIX}/share/lxqt"))
+ #t)))))
+ (home-page "https://lxqt.org/")
+ (synopsis "Themes, graphics and icons for LXQt")
+ (description "This package comprises a number of graphic files and themes
+for LXQt.")
+ ;; The whole package is released under LGPL 2.1+, while the LXQt logo is
+ ;; licensed under CC-BY-SA 3.0.
+ (license license:lgpl2.1+)))
+
+
+;; File Manager
+
+(define-public libfm-qt
+ (package
+ (name "libfm-qt")
+ (version "0.13.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
+ version "/" name "-" version ".tar.xz"))
+ (sha256
+ (base32 "0p0lbz7dh5c38zq3yp1v1mm99ymg7mqr3h7yzniif2hipmgvxsv9"))))
(build-system cmake-build-system)
+ (arguments
+ '(#:tests? #f ; no tests
+ #:configure-flags
+ ;; TODO : prefetch translations files from 'lxqt-l10n'.
+ '("-DPULL_TRANSLATIONS=NO")))
(inputs
`(("glib" ,glib)
+ ("libexif" ,libexif)
+ ("libfm" ,libfm)
+ ("libxcb" ,libxcb)
+ ("menu-cache" ,menu-cache)
("pcre" ,pcre)
- ("pulseaudio" ,pulseaudio)
("qtbase" ,qtbase)
("qtx11extras" ,qtx11extras)))
(native-inputs
`(("pkg-config" ,pkg-config)
("lxqt-build-tools" ,lxqt-build-tools)
("qttools" ,qttools)))
- (arguments
- '(#:tests? #f ; no tests
- #:configure-flags
- ;; TODO: prefetch translations files from 'lxqt-l10n'.
- '("-DPULL_TRANSLATIONS=NO")))
(home-page "https://lxqt.org/")
- (synopsis "Pulseaudio mixer in Qt")
- (description "@code{pavucontrol-qt} is the Qt port of volume control
-@code{pavucontrol} of sound server @code{PulseAudio}.")
+ (synopsis "Qt binding for libfm")
+ (description "libfm-qt is the Qt port of libfm, a library providing
+components to build desktop file managers which belongs to LXDE.")
(license license:lgpl2.1+)))
(define-public pcmanfm-qt
@@ -918,6 +897,42 @@ permissions of other users including root.")
LXDE.")
(license license:lgpl2.1+)))
+
+;; Extra
+
+(define-public pavucontrol-qt
+ (package
+ (name "pavucontrol-qt")
+ (version "0.4.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
+ version "/" name "-" version ".tar.xz"))
+ (sha256
+ (base32 "0pqvhhgw7d00wqw5v3ghm4l8250zy7bqpvhff6l7y1lw0z2fvcp6"))))
+ (build-system cmake-build-system)
+ (inputs
+ `(("glib" ,glib)
+ ("pcre" ,pcre)
+ ("pulseaudio" ,pulseaudio)
+ ("qtbase" ,qtbase)
+ ("qtx11extras" ,qtx11extras)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("lxqt-build-tools" ,lxqt-build-tools)
+ ("qttools" ,qttools)))
+ (arguments
+ '(#:tests? #f ; no tests
+ #:configure-flags
+ ;; TODO: prefetch translations files from 'lxqt-l10n'.
+ '("-DPULL_TRANSLATIONS=NO")))
+ (home-page "https://lxqt.org/")
+ (synopsis "Pulseaudio mixer in Qt")
+ (description "@code{pavucontrol-qt} is the Qt port of volume control
+@code{pavucontrol} of sound server @code{PulseAudio}.")
+ (license license:lgpl2.1+)))
+
(define-public qtermwidget
(package
(name "qtermwidget")