summaryrefslogtreecommitdiff
path: root/gnu/packages/lxqt.scm
diff options
context:
space:
mode:
authorMeiyo Peng <meiyo.peng@gmail.com>2018-10-18 10:35:56 +0800
committer宋文武 <iyzsong@member.fsf.org>2018-10-23 21:33:45 +0800
commit088096aa0e0567a1d3d666322c3e919069216261 (patch)
treef9080a8771539aea0a6355a8dd2416b68aed4c0f /gnu/packages/lxqt.scm
parent70c488f8ddfbf21301f215424c4bdcc7cf6e9936 (diff)
downloadgnu-guix-088096aa0e0567a1d3d666322c3e919069216261.tar
gnu-guix-088096aa0e0567a1d3d666322c3e919069216261.tar.gz
gnu: lxqt-build-tools: Update download URL and home page URL.
* gnu/packages/lxqt.scm (lxqt-build-tools) [source]: Update download URL to the 'lxqt' repository. [home-page]: Use HTTPS. Signed-off-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu/packages/lxqt.scm')
-rw-r--r--gnu/packages/lxqt.scm10
1 files changed, 4 insertions, 6 deletions
diff --git a/gnu/packages/lxqt.scm b/gnu/packages/lxqt.scm
index a25984db73..49a7040bcc 100644
--- a/gnu/packages/lxqt.scm
+++ b/gnu/packages/lxqt.scm
@@ -166,12 +166,10 @@ for the LXQt desktop environment.")
(source
(origin
(method url-fetch)
- (uri (string-append "https://github.com/lxde/lxqt-build-tools/releases/"
- "download/" version "/" name "-" version ".tar.xz"))
- (file-name (string-append name "-" version ".tar.xz"))
+ (uri (string-append "https://github.com/lxqt/" name "/releases/download/"
+ version "/" name "-" version ".tar.xz"))
(sha256
- (base32
- "13b5x26p6ycnwzlgg1cgvlc88wjrjmlb3snrrmzh0xgh9h6hhvd6"))))
+ (base32 "13b5x26p6ycnwzlgg1cgvlc88wjrjmlb3snrrmzh0xgh9h6hhvd6"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f)) ; no tests
@@ -184,5 +182,5 @@ for the LXQt desktop environment.")
(description
"Lxqt-build-tools is providing several tools needed to build LXQt
itself as well as other components maintained by the LXQt project.")
- (home-page "http://lxqt.org")
+ (home-page "https://lxqt.org")
(license lgpl2.1+)))