summaryrefslogtreecommitdiff
path: root/gnu/packages/lxde.scm
diff options
context:
space:
mode:
authorMathieu Lirzin <mthl@openmailbox.org>2015-07-15 22:42:25 +0200
committerMathieu Lirzin <mthl@openmailbox.org>2015-07-22 00:15:16 +0200
commit753dc7d311267f782d096e5fc59cc00f55bd9cde (patch)
treecbf0010ca33fb2e631c13730e042b8355f3d3098 /gnu/packages/lxde.scm
parentb3527d5d585716915fff6d42931cedcbac22717c (diff)
downloadgnu-guix-753dc7d311267f782d096e5fc59cc00f55bd9cde.tar
gnu-guix-753dc7d311267f782d096e5fc59cc00f55bd9cde.tar.gz
gnu: Add lxterminal.
* gnu/packages/lxde.scm (lxterminal): New variable.
Diffstat (limited to 'gnu/packages/lxde.scm')
-rw-r--r--gnu/packages/lxde.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/lxde.scm b/gnu/packages/lxde.scm
index 209fb80ffc..3d63d12863 100644
--- a/gnu/packages/lxde.scm
+++ b/gnu/packages/lxde.scm
@@ -89,6 +89,31 @@ able to change themes, icons, and fonts used by GTK+ applications.")
(home-page "http://lxde.org")
(license license:gpl2+)))
+(define-public lxterminal
+ (package
+ (name "lxterminal")
+ (version "0.2.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/project/lxde/LXTerminal"
+ "%20%28terminal%20emulator%29/LXTerminal%20"
+ version "/" name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1brb506vmnncih8nyvlrckrrn6msbsvz2vwbm7bsqwigcnchwjqp"))))
+ (build-system gnu-build-system)
+ (inputs `(("gtk+" ,gtk+-2)
+ ("vte" ,vte/gtk+-2)))
+ (native-inputs `(("intltool" ,intltool)
+ ("pkg-config" ,pkg-config)))
+ (synopsis "LXDE terminal emulator")
+ (description "LXTerminal is a VTE-based terminal emulator. It supports
+multiple tabs and has only minimal dependencies thus being completely
+desktop-independent. In order to reduce memory usage and increase the
+performance, all instances of the terminal are sharing a single process.")
+ (home-page "http://lxde.org")
+ (license license:gpl2+)))
+
(define-public menu-cache
(package
(name "menu-cache")