summaryrefslogtreecommitdiff
path: root/gnu/packages/lisp.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2018-11-24 15:18:12 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2018-11-24 15:20:51 +0100
commit96cfa168e50c3e61ba83899ef25808f0066fff72 (patch)
tree95d5e3d6c6e58a49fcd97b4ff8e7f346d5092904 /gnu/packages/lisp.scm
parente83c7d1abaf4fc56165e8307c8b49327b98327f8 (diff)
downloadgnu-guix-96cfa168e50c3e61ba83899ef25808f0066fff72.tar
gnu-guix-96cfa168e50c3e61ba83899ef25808f0066fff72.tar.gz
gnu: clojure: Move to new clojure.scm.
* gnu/local.mk (clojure): Include new clojure.scm. * gnu/packages/clojure.scm: Add clojure, clojure-algo-generic, clojure-algo-monads, clojure-core-match, clojure-instaparse, clojure-tools-macro. * gnu/packages/lisp.scm: Remove clojure, clojure-algo-generic, clojure-algo-monads, clojure-core-match, clojure-instaparse, clojure-tools-macro.
Diffstat (limited to 'gnu/packages/lisp.scm')
-rw-r--r--gnu/packages/lisp.scm266
1 files changed, 0 insertions, 266 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 741eaf2a45..37ce6fa983 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -36,7 +36,6 @@
#:use-module (guix utils)
#:use-module (guix build-system gnu)
#:use-module (guix build-system ant)
- #:use-module (guix build-system clojure)
#:use-module (guix build-system asdf)
#:use-module (guix build-system trivial)
#:use-module (gnu packages admin)
@@ -565,119 +564,6 @@ interface.")
(license (list license:lgpl2.1
license:clarified-artistic)))) ;TRIVIAL-LDAP package
-(define-public clojure
- (let* ((lib (lambda (prefix version hash)
- (origin (method url-fetch)
- (uri (string-append "https://github.com/clojure/"
- prefix version ".tar.gz"))
- (sha256 (base32 hash)))))
- ;; The libraries below are needed to run the tests.
- (libraries
- `(("core-specs-alpha-src"
- ,(lib "core.specs.alpha/archive/core.specs.alpha-"
- "0.1.24"
- "0v2a0svf1ar2y42ajxwsjr7zmm5j7pp2zwrd2jh3k7xzd1p9x1fv"))
- ("data-generators-src"
- ,(lib "data.generators/archive/data.generators-"
- "0.1.2"
- "0kki093jp4ckwxzfnw8ylflrfqs8b1i1wi9iapmwcsy328dmgzp1"))
- ("spec-alpha-src"
- ,(lib "spec.alpha/archive/spec.alpha-"
- "0.1.143"
- "00alf0347licdn773w2jarpllyrbl52qz4d8mw61anjksacxylzz"))
- ("test-check-src"
- ,(lib "test.check/archive/test.check-"
- "0.9.0"
- "0p0mnyhr442bzkz0s4k5ra3i6l5lc7kp6ajaqkkyh4c2k5yck1md"))
- ("test-generative-src"
- ,(lib "test.generative/archive/test.generative-"
- "0.5.2"
- "1pjafy1i7yblc7ixmcpfq1lfbyf3jaljvkgrajn70sws9xs7a9f8"))
- ("tools-namespace-src"
- ,(lib "tools.namespace/archive/tools.namespace-"
- "0.2.11"
- "10baak8v0hnwz2hr33bavshm7y49mmn9zsyyms1dwjz45p5ymhy0"))))
- (library-names (match libraries
- (((library-name _) ...)
- library-name))))
-
- (package
- (name "clojure")
- (version "1.9.0")
- (source
- (origin
- (method url-fetch)
- (uri
- (string-append "https://github.com/clojure/clojure/archive/clojure-"
- version ".tar.gz"))
- (sha256
- (base32 "0xjbzcw45z32vsn9pifp7ndysjzqswp5ig0jkjpivigh2ckkdzha"))))
- (build-system ant-build-system)
- (arguments
- `(#:imported-modules ((guix build clojure-utils)
- (guix build guile-build-system)
- ,@%ant-build-system-modules)
- #:modules ((guix build ant-build-system)
- (guix build clojure-utils)
- (guix build java-utils)
- (guix build utils)
- (srfi srfi-26))
- #:test-target "test"
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'unpack-library-sources
- (lambda* (#:key inputs #:allow-other-keys)
- (define (extract-library name)
- (mkdir-p name)
- (with-directory-excursion name
- (invoke "tar"
- "--extract"
- "--verbose"
- "--file" (assoc-ref inputs name)
- "--strip-components=1"))
- (copy-recursively (string-append name "/src/main/clojure/")
- "src/clj/"))
- (for-each extract-library ',library-names)
- #t))
- (add-after 'unpack-library-sources 'fix-manifest-classpath
- (lambda _
- (substitute* "build.xml"
- (("<attribute name=\"Class-Path\" value=\".\"/>") ""))
- #t))
- (add-after 'build 'build-javadoc ant-build-javadoc)
- (replace 'install (install-jars "./"))
- (add-after 'install-license-files 'install-doc
- (cut install-doc #:doc-dirs '("doc/clojure/") <...>))
- (add-after 'install-doc 'install-javadoc
- (install-javadoc "target/javadoc/")))))
- (native-inputs libraries)
- (home-page "https://clojure.org/")
- (synopsis "Lisp dialect running on the JVM")
- (description "Clojure is a dynamic, general-purpose programming language,
-combining the approachability and interactive development of a scripting
-language with an efficient and robust infrastructure for multithreaded
-programming. Clojure is a compiled language, yet remains completely dynamic
-– every feature supported by Clojure is supported at runtime. Clojure
-provides easy access to the Java frameworks, with optional type hints and type
-inference, to ensure that calls to Java can avoid reflection.
-
-Clojure is a dialect of Lisp, and shares with Lisp the code-as-data philosophy
-and a powerful macro system. Clojure is predominantly a functional programming
-language, and features a rich set of immutable, persistent data structures.
-When mutable state is needed, Clojure offers a software transactional memory
-system and reactive Agent system that ensure clean, correct, multithreaded
-designs.")
- ;; Clojure is licensed under EPL1.0
- ;; ASM bytecode manipulation library is licensed under BSD-3
- ;; Guava Murmur3 hash implementation is licensed under APL2.0
- ;; src/clj/repl.clj is licensed under CPL1.0
-
- ;; See readme.html or readme.txt for details.
- (license (list license:epl1.0
- license:bsd-3
- license:asl2.0
- license:cpl1.0)))))
-
(define-public lush2
(package
(name "lush2")
@@ -1557,158 +1443,6 @@ compressor. It works on data produced by @code{parse-js} to generate a
("sbcl-cl-uglify-js" ,sbcl-cl-uglify-js)))
(synopsis "JavaScript compressor")))
-(define-public clojure-algo-generic
- (package
- (name "clojure-algo-generic")
- (version "0.1.3")
- (source
- (origin
- (method url-fetch)
- (uri
- (string-append "https://github.com/clojure/algo.generic/archive"
- "/algo.generic-" version ".tar.gz"))
- (sha256
- (base32 "12w9681i545gp1af4576z1qbixwps1j13c16fmcc7zsb0bd1zr7w"))))
- (build-system clojure-build-system)
- (arguments
- '(#:source-dirs '("src/main/clojure/")
- #:test-dirs '("src/test/clojure/")
- #:doc-dirs '()))
- (synopsis "Generic versions of common functions")
- (description
- "Generic versions of commonly used functions, implemented as multimethods
-that can be implemented for any data type.")
- (home-page "https://github.com/clojure/algo.generic")
- (license license:epl1.0)))
-
-(define-public clojure-algo-monads
- (package
- (name "clojure-algo-monads")
- (version "0.1.6")
- (source
- (origin
- (method url-fetch)
- (uri
- (string-append "https://github.com/clojure/algo.monads/archive"
- "/algo.monads-" version ".tar.gz"))
- (sha256
- (base32 "14gbvfgmrda990h45yn7zag83vp1kdkz4f4yzmyvkr0sjihlgdmq"))))
- (build-system clojure-build-system)
- (arguments
- '(#:source-dirs '("src/main/clojure/")
- #:test-dirs '("src/test/clojure/")
- #:doc-dirs '()))
- (native-inputs
- `(("clojure-tools-macro" ,clojure-tools-macro)))
- (synopsis
- "Monad Macros and Definitions")
- (description
- "This library contains the most commonly used monads as well as macros for
-defining and using monads and useful monadic functions.")
- (home-page "https://github.com/clojure/algo.monads")
- (license license:epl1.0)))
-
-(define-public clojure-core-match
- (let ((commit "1837ffbd4a150e8f3953b2d9ed5cf4a4ad3720a7")
- (revision "1")) ; this is the 1st commit buildable with clojure 1.9
- (package
- (name "clojure-core-match")
- (version (git-version "0.3.0-alpha5" revision commit))
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/clojure/core.match.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "04bdlp5dgkrqzrz0lw3mfwmygj2218qnm1cz3dkb9wy4m0238s4d"))))
- (build-system clojure-build-system)
- (arguments
- '(#:source-dirs '("src/main/clojure")
- #:test-dirs '("src/test/clojure")
- #:doc-dirs '()))
- (synopsis "Optimized pattern matching for Clojure")
- (description
- "An optimized pattern matching library for Clojure.
-It supports Clojure 1.5.1 and later as well as ClojureScript.")
- (home-page "https://github.com/clojure/core.match")
- (license license:epl1.0))))
-
-(define-public clojure-instaparse
- (let ((commit "dcfffad5b065e750f0f5835f017cdd8188b8ca2e")
- (version "1.4.9")) ; upstream forget to tag this release
- (package
- (name "clojure-instaparse")
- (version version)
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/Engelberg/instaparse.git")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "002mrgin4z3dqy88r1lak7smd0m7x8d22vmliw0m6w6mh5pa17lk"))))
- (build-system clojure-build-system)
- (arguments
- '(#:doc-dirs '("docs/")))
- (synopsis "No grammar left behind")
- (description
- "Instaparse aims to be the simplest way to build parsers in Clojure.
-
-@itemize
-@item Turns @emph{standard EBNF or ABNF notation} for context-free grammars
-into an executable parser that takes a string as an input and produces a parse
-tree for that string.
-
-@item @dfn{No Grammar Left Behind}: Works for @emph{any} context-free grammar,
-including @emph{left-recursive}, @emph{right-recursive}, and @emph{ambiguous}
-grammars.
-
-@item Extends the power of context-free grammars with PEG-like syntax for
-lookahead and negative lookahead.
-
-@item Supports both of Clojure's most popular tree formats (hiccup and enlive)
-as output targets
-
-@item Detailed reporting of parse errors.
-
-@item Optionally produces lazy sequence of all parses (especially useful for
-diagnosing and debugging ambiguous grammars).
-
-@item ``Total parsing'' mode where leftover string is embedded in the parse
-tree.
-
-@item Optional combinator library for building grammars programmatically.
-
-@item Performant.
-@end itemize")
- (home-page "https://github.com/Engelberg/instaparse")
- (license license:epl1.0))))
-
-(define-public clojure-tools-macro
- (package
- (name "clojure-tools-macro")
- (version "0.1.5")
- (source
- (origin
- (method url-fetch)
- (uri
- (string-append "https://github.com/clojure/tools.macro/archive"
- "/tools.macro-" version ".tar.gz"))
- (sha256
- (base32 "0fs64a0g63xx6g7sj6vrsqknhl90s0isf6k053nw8vv5prfzc7v6"))))
- (build-system clojure-build-system)
- (arguments
- '(#:source-dirs '("src/main/clojure/")
- #:test-dirs '("src/test/clojure/")
- #:doc-dirs '()))
- (synopsis "Utilities for macro writers")
- (description "Tools for writing macros.")
- (home-page "https://github.com/clojure/tools.macro")
- (license license:epl1.0)))
-
(define-public confusion-mdl
(let* ((commit "12a055581fc262225272df43287dae48281900f5"))
(package