summaryrefslogtreecommitdiff
path: root/gnu/packages/libevent.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2017-03-19 18:52:01 -0400
committerMark H Weaver <mhw@netris.org>2017-03-19 18:52:12 -0400
commitf67337e23ec16b1e05fcdcc7953f68f13ed6770a (patch)
tree766e98a6c4695228f0a066accf91f639791dad68 /gnu/packages/libevent.scm
parentb99eec83b861f6bee7afb7bd6ffcbdddd8f62b65 (diff)
parente05fc441cd5528ba6c83b6371c27c1e87dd393e9 (diff)
downloadgnu-guix-f67337e23ec16b1e05fcdcc7953f68f13ed6770a.tar
gnu-guix-f67337e23ec16b1e05fcdcc7953f68f13ed6770a.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/libevent.scm')
-rw-r--r--gnu/packages/libevent.scm28
1 files changed, 15 insertions, 13 deletions
diff --git a/gnu/packages/libevent.scm b/gnu/packages/libevent.scm
index 551fbf7206..1bfdefd7b5 100644
--- a/gnu/packages/libevent.scm
+++ b/gnu/packages/libevent.scm
@@ -1,6 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2014, 2015, 2016 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2015, 2017 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Eric Dvorsak <eric@dvorsak.fr>
;;; Copyright © 2016 David Thompson <davet@gnu.org>
;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
@@ -74,18 +74,20 @@ loop.")
(inherit libevent)
(version "2.0.22")
(source (origin
- (method url-fetch)
- (uri (string-append
- "https://github.com/libevent/libevent/releases/download/release-"
- version "-stable/libevent-" version "-stable.tar.gz"))
- (sha256
- (base32
- "18qz9qfwrkakmazdlwxvjmw8p76g70n3faikwvdwznns1agw9hki"))
- (patches (search-patches
- "libevent-dns-tests.patch"
- "libevent-2.0-CVE-2016-10195.patch"
- "libevent-2.0-CVE-2016-10196.patch"
- "libevent-2.0-CVE-2016-10197.patch"))))))
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/libevent/libevent/releases/download/release-"
+ version "-stable/libevent-" version "-stable.tar.gz"))
+ (sha256
+ (base32
+ "18qz9qfwrkakmazdlwxvjmw8p76g70n3faikwvdwznns1agw9hki"))
+ (patches
+ (search-patches
+ "libevent-dns-tests.patch"
+ "libevent-2.0-CVE-2016-10195.patch"
+ "libevent-2.0-CVE-2016-10196.patch"
+ "libevent-2.0-CVE-2016-10197.patch"
+ "libevent-2.0-evbuffer-add-use-last-with-datap.patch"))))))
(define-public libev
(package