summaryrefslogtreecommitdiff
path: root/gnu/packages/ldc.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2017-02-01 10:51:32 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2017-02-10 12:13:54 +0100
commit836cbd9f72fa3e2bcd4102c3db1b6f3c0671ed2f (patch)
tree4c6796891e0ec4a5f5d9a4ca433954ffa5ae50da /gnu/packages/ldc.scm
parentbeffaf9a124e846eddd1519020c08ec6628fcd78 (diff)
downloadgnu-guix-836cbd9f72fa3e2bcd4102c3db1b6f3c0671ed2f.tar
gnu-guix-836cbd9f72fa3e2bcd4102c3db1b6f3c0671ed2f.tar.gz
gnu: ldc: Update to 1.1.0.
* gnu/packages/ldc.scm (ldc-1.1.0-beta6): Rename to... (ldc): ... this. [version]: Modify. [source]: Modify. (ldc-beta): Modify.
Diffstat (limited to 'gnu/packages/ldc.scm')
-rw-r--r--gnu/packages/ldc.scm16
1 files changed, 8 insertions, 8 deletions
diff --git a/gnu/packages/ldc.scm b/gnu/packages/ldc.scm
index 778809968e..eabd02827c 100644
--- a/gnu/packages/ldc.scm
+++ b/gnu/packages/ldc.scm
@@ -176,15 +176,15 @@ latest DMD frontend and uses LLVM as backend.")
license:boost1.0))))
-(define-public ldc-1.1.0-beta6
+(define-public ldc
;; The phobos, druntime and dmd-testsuite dependencies do not have a newer
;; release than 1.1.0-beta4, hence the need to make use of the older-version
;; variable to hold this variable.
- (let ((older-version "1.1.0-beta4"))
+ (let ((older-version "1.1.0"))
(package
(inherit ldc-bootstrap)
(name "ldc")
- (version "1.1.0-beta6")
+ (version "1.1.0")
;; Beta version needed to compile various scientific tools that require
;; the newer beta versions, and won't compile successfully with the
;; older stable version.
@@ -196,7 +196,7 @@ latest DMD frontend and uses LLVM as backend.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "0n53brlkm86jjkppy9xmzx7nyxykzj68kcxgv8q7d10s5hfscxs8"))))
+ "10zkrmx9bcmhfxvgykm3fkjamzc8js96wm032bv0fyil5c9ja2y1"))))
(arguments
`(#:phases
(modify-phases %standard-phases
@@ -240,7 +240,7 @@ latest DMD frontend and uses LLVM as backend.")
older-version ".tar.gz"))
(sha256
(base32
- "1iwy5rs0rqkicj1zfsa5yqvk8ard99bfr8g69qmhlbzb98q0kpks"))
+ "0z5v55b9s1ppf0c2ivjq7sbmq688c37c92ihc3qwrbxnqvkkvrlk"))
;; This patch deactivates some tests that depend on network access
;; to pass. It also deactivates some tests that have some reliance
;; on timezone.
@@ -259,7 +259,7 @@ latest DMD frontend and uses LLVM as backend.")
older-version ".tar.gz"))
(sha256
(base32
- "1qsiw5lz1pr8ms9myjf8b94nqi7f1781k226jvxwnhkjg11d0s63"))))
+ "07qvrqj6vgakd6qr4x5f70w6zwkzd1li5x8i1b5ywnds1z5lnfp6"))))
("dmd-testsuite-src"
,(origin
(method url-fetch)
@@ -268,13 +268,13 @@ latest DMD frontend and uses LLVM as backend.")
older-version ".tar.gz"))
(sha256
(base32
- "0jp54hyi75i9g41rvgmm3zg21yzv57q8dghrhb432rb0n9j15mbp"))
+ "12cak7yqmsgjlflx0dp6fwmwb9dac25amgi86n0bb95ard3547wy"))
;; Remove the gdb tests that fails with a "Error: No such file or
;; directory" error, despite the files being present in the debug
;; files left with the --keep-failed flag to guix build.
(patches (search-patches "ldc-1.1.0-disable-dmd-tests.patch")))))))))
-(define-public ldc-beta ldc-1.1.0-beta6)
+(define-public ldc-beta ldc)
(define-public dub
(package