summaryrefslogtreecommitdiff
path: root/gnu/packages/kde-frameworks.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2017-09-19 19:45:58 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2017-10-13 13:53:44 +0200
commitba81085b2594e63c7b89c2c8517ca9f42d7feed2 (patch)
tree62cef639d8cb70b1a8409c9f12c4827c7df2c032 /gnu/packages/kde-frameworks.scm
parent11f65700114231198ad9d80a71eebe6ab7b18d73 (diff)
downloadgnu-guix-ba81085b2594e63c7b89c2c8517ca9f42d7feed2.tar
gnu-guix-ba81085b2594e63c7b89c2c8517ca9f42d7feed2.tar.gz
gnu: phonon: Enable building the Qt Designer plugin.
Add native-inputs pkg-config, qttools and update comments. This enables building the Qt Designer plugin. * gnu/packages/kde-frameworks.scm (phonon): [native-inputs]: Add pkg-config, qttools. [arguments]<#configure-flags>: Remove PHONON_INSTALL_QT_EXTENSIONS_INTO_SYSTEM_QT, to avoid installing the Phonon-Qt-extension into /gnu/store/…-qtbase-…/.
Diffstat (limited to 'gnu/packages/kde-frameworks.scm')
-rw-r--r--gnu/packages/kde-frameworks.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index cb84750492..a57ff4f458 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -138,16 +138,17 @@ common build settings used in software produced by the KDE community.")
"177647r2jqfm32hqcz2nqfqv6v48hn5ab2vc31svba2wz23fkgk7"))))
(build-system cmake-build-system)
(native-inputs
- ;; TODO: Add qttools to build the Qt Designer plugin.
;; TODO: Think about adding pulseaudio. Is it required for sound?
- `(("extra-cmake-modules" ,extra-cmake-modules)))
+ ;; TODO: Add building the super experimental QML support
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("pkg-config" ,pkg-config)
+ ("qttools", qttools)))
(inputs
`(("qtbase" ,qtbase)))
(arguments
`(#:configure-flags
'("-DCMAKE_CXX_FLAGS=-fPIC"
- "-DPHONON_BUILD_PHONON4QT5=ON"
- "-DPHONON_INSTALL_QT_EXTENSIONS_INTO_SYSTEM_QT=ON")
+ "-DPHONON_BUILD_PHONON4QT5=ON")
#:phases
(modify-phases %standard-phases
(add-before 'install 'patch-installdir