summaryrefslogtreecommitdiff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-09-10 01:00:26 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-09-10 01:00:26 +0200
commitfb94354a69cacbeed1a24d30c46ba7f056186b65 (patch)
tree8b2be2abab608db7c558b0e5e64d3d2f8c542dc6 /gnu/packages/image.scm
parent18784d8f11f62a3ebeb4050ff2d8be5e3623dbbf (diff)
downloadgnu-guix-fb94354a69cacbeed1a24d30c46ba7f056186b65.tar
gnu-guix-fb94354a69cacbeed1a24d30c46ba7f056186b65.tar.gz
gnu: jbig2dec: Remove graft for 0.15.
* gnu/packages/image.scm (jbig2dec): Update to 0.15. [source]: Reindent. (jbig2dec-0.15): Remove variable.
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm36
1 files changed, 10 insertions, 26 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 451e7b14a1..62fc26ab91 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -485,17 +485,16 @@ arithmetic ops.")
(define-public jbig2dec
(package
(name "jbig2dec")
- (version "0.14")
- (replacement jbig2dec-0.15)
- (source
- (origin
- (method url-fetch)
- (uri
- (string-append "https://github.com/ArtifexSoftware/ghostpdl-downloads/"
- "releases/download/gs922/" name "-" version ".tar.gz"))
- (sha256
- (base32 "0k01hp0q4275fj4rbr1gy64svfraw5w7wvwl08yjhvsnpb1rid11"))
- (patches (search-patches "jbig2dec-ignore-testtest.patch"))))
+ (version "0.15")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/ArtifexSoftware"
+ "/ghostpdl-downloads/releases/download"
+ "/gs924/" name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0m1qwpbjbirgw2fqznbajdhdhh35d6xa2csr64lpjz735pvimykb"))
+ (patches (search-patches "jbig2dec-ignore-testtest.patch"))))
(build-system gnu-build-system)
(arguments '(#:configure-flags '("--disable-static")))
(synopsis "Decoder of the JBIG2 image compression format")
@@ -512,21 +511,6 @@ work.")
(home-page "https://jbig2dec.com")
(license license:gpl2+)))
-;; This is a bugfix release from an ongoing Ghostscript security audit.
-;; It was released alongside Ghostscript 9.24.
-(define-public jbig2dec-0.15
- (package
- (inherit jbig2dec)
- (version "0.15")
- (source (origin
- (inherit (package-source jbig2dec))
- (uri (string-append "https://github.com/ArtifexSoftware"
- "/ghostpdl-downloads/releases/download/gs924/"
- "jbig2dec-" version ".tar.gz"))
- (sha256
- (base32
- "0m1qwpbjbirgw2fqznbajdhdhh35d6xa2csr64lpjz735pvimykb"))))))
-
(define-public openjpeg
(package
(name "openjpeg")