summaryrefslogtreecommitdiff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-08-02 11:16:30 -0400
committerLeo Famulari <leo@famulari.name>2017-08-02 11:17:57 -0400
commit696f1d0fb1d3f5211d9b38d0f70a5f5c9055a641 (patch)
tree7dc35538a8a6c19d82dc09bbd81bfd7131e6c285 /gnu/packages/image.scm
parente0958c2df833a5eb3b6ecfb66f8d971cd44dd49b (diff)
downloadgnu-guix-696f1d0fb1d3f5211d9b38d0f70a5f5c9055a641.tar
gnu-guix-696f1d0fb1d3f5211d9b38d0f70a5f5c9055a641.tar.gz
gnu: libpng-apng: Be sure to apply the APNG patch.
* gnu/packages/image.scm (libpng-apng)[arguments]: Check the return status of the patching procedures.
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index ab560d2acb..63e3fa5049 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -113,7 +113,10 @@ library. It supports almost all PNG features and is extensible.")
"0ylgyx93hnk38haqrh8prd3ax5ngzwvjqw5cxw7p9nxmwsfyrlyq"))))
(build-system gnu-build-system)
(arguments
- `(#:phases
+ `(#:modules ((guix build gnu-build-system)
+ (guix build utils)
+ (srfi srfi-1))
+ #:phases
(modify-phases %standard-phases
(add-after 'unpack 'patch-apng
(lambda* (#:key inputs #:allow-other-keys)
@@ -123,11 +126,10 @@ library. It supports almost all PNG features and is extensible.")
(let ((apng.gz (assoc-ref inputs "apng")))
(format #t "Applying APNG patch '~a'...~%"
apng.gz)
- (system (string-append "gunzip < " apng.gz " > the-patch"))
- (and (apply-patch "the-patch")
- (for-each apply-patch
- (find-files "\\.patch"))))
- #t))
+ (and
+ (zero?
+ (system (string-append "gunzip < " apng.gz " > the-patch")))
+ (apply-patch "the-patch")))))
(add-before 'configure 'no-checks
(lambda _
(substitute* "Makefile.in"